Need Help Installing Software - Receiving .NET Runtime Error

jacenbourne

Reputable
Sep 25, 2014
12
0
4,510
0
Hi all,

I was really excited to come home from work today and see the nice brown package left for me that contained a Cessna Trim Wheel and 2 Saitek Pro Flight Instrument Panels... you can imagine my disappointment when I cannot get the Instrument Panels to work (the Trim Wheel works fine!).

System Stats:
Windows 8.1 (64 bit) running .NET Framework 4.5
RAM: 16 GB
CPU: Intel i7 (3.8 Ghz)

The error I'm getting is screenshotted here: http://imgur.com/Hs6gNQr . Everytime I run the setup from the included CD, I get that error. I've tried running it in compatibility mode for XP SP2 to no avail. I have tried installing the .NET Framework 2.0 and when I run it I get a windows error (my thoughts are that it's because it's not compatible with Windows 8 since 2.0 is from XP...). I've emailed the company to help, their first response was, "Download and run the .NET Runtime 2.0" (that was it, after explaining in the email that that wouldn't work and I had tried) so I'm trying to find a possible alternative fix.

When I get home from work, one of the things that I am going to try is seeing if I can install 3.5 and then turn the feature on/off.

I downloaded the latest drivers from Saitek's website and installed them, but that doesn't include the SST Programming Software, which is what has all the gauges...

Help would be much appreciated!
Thanks,
- Jace
 

Wolfshadw

Titan
Moderator
Often, the software and drivers that come on the included CD are not up to date. It could be that the CD you received does not include the appropriate drivers/net framework for Windows 8. I'd suggest downloading the software direct from Saitek and see if that works.

-Wolf sends
 

jacenbourne

Reputable
Sep 25, 2014
12
0
4,510
0


Hi Wolf,

Thanks for your help. And yeah, it looks like the software hasn't been updated since XP, haha! I did download the latest drivers from Saitek's site, but it doesn't include the programming software, which is needed to make the equipment work, so right now the only thing I have that has that software on it is the Software CD, which is giving me this error when I try to run it.
 

jacenbourne

Reputable
Sep 25, 2014
12
0
4,510
0


I've downloaded everything from Windows Updates already, as mentioned, I'm currently running .NET Framework 4.5.1 on my computer. The CD is telling me that I need 2.0, but I can't install that old of a version on my PC.
 

jacenbourne

Reputable
Sep 25, 2014
12
0
4,510
0


Whoops, didn't mean to hit that as the solution....

I've downloaded all the Windows Updates (downloaded a small one yesterday), but I'll check again this afternoon. I don't think that will fix it though :/.
 

jacenbourne

Reputable
Sep 25, 2014
12
0
4,510
0


Thank you sir!

You and me both. Only thing I can think of is that they literally haven't updated their software since XP came out, but they have updated the drivers... I've emailed them a detailed description with screenshots of what's going on, and like I said, their response was basically "Follow the link and download it." Which made my confidence in their tech's go way down. I've replied saying that it doesn't work, but have not heard back yet. It's a really cool product and I'd hate to send it back which is why I'm going to such lengths to find a solution.

 

jacenbourne

Reputable
Sep 25, 2014
12
0
4,510
0


I tried running it in compatibility mode and it still didn't work, and I am an admin. I did try running it as admin as well, same issue.
 

jacenbourne

Reputable
Sep 25, 2014
12
0
4,510
0


I can't install it so there's nothing to uninstall, I can try in safe mode but I'm not sure that's going to help with a .NET Runtime error, and the only security app I was running was Malwarebytes, which I can kill and try again.
 
sometimes you have to do updates incrementally. I don't know what's in 3.5 and I know netframework goes beyond 3.5. So I would start from the beginning and not miss anything........ also, why hasn't windows updates offered you any updates for this? doesn't sound right.
 

jacenbourne

Reputable
Sep 25, 2014
12
0
4,510
0


Hopefully this helps explain it some:

Windows Update isn't coming up with any new updates, and it says I'm running .NET 4.5.1. When I click "Turn Windows Features On or Off" it comes up as a blank white box, which from what I've read is a common issue with Windows 8. I tried to fix it using a few solutions, such as using the CMD console to run a updates scan, clean and repair with DISM, but everytime I tried to run it I got error... 87, I believe it was. The syntax used was correct. I tried another route using scr... I think it was? Again, an error. I probably do have 3.5 on my computer, but I can't turn it on because the box is blank, so now I'm trying to find a fix for an error that's a fix for an error that's a fix for an error. My patience is dying haha.

I'm going to try and partition a 50-100 GB portion of my HDD and install XP SP2 on it. All of the Flight Sim equipment I have is definitely compatible with XP, and if it prevents all of these headaches, I'm willing to do it that way. Of course this would have been much easier had Saitek made a version of their software compatible with WIN 8 (even though it says it is...).
 

orlbuckeye

Distinguished
May 1, 2009
1,526
0
20,160
177


I'm not a .net developer but I design app that programmers write apps in .net. I was told that .net framework versions cumulative meaning 4.5 doesn't have 2.0, 3.0 or other earlier version. Well if it requires 2.0 and 2.0 doesn't install in Windows 8.1 it might not be compatible with Windows 8.1. I would contact the vendor support and should be able to say if compatible and if it isn't they may have something to fix it.
 

jacenbourne

Reputable
Sep 25, 2014
12
0
4,510
0


I tried to install .NET 2.0 and 3.5 and received an error message for each. Saitek emailed me this morning saying to download the latest version of the software off their website.

To which I responded, I'd love to! But you don't have the software on your website, just the drivers! If you'll send me the new version of the software, I'd be happy to install it. I'm really not getting anywhere with their support, just 1 sentence replies that tell me to do something I already told them I had tried and it didn't work.
 

ASK THE COMMUNITY

TRENDING THREADS