Question Need help pc keeps restarting after trying to open a game.

May 2, 2021
6
1
15
0
Hey everyone thabk you for your time. So i have a fairly new custom pc. Its not even a month old. I was buying the pieces little by little. Ive been gaming for about 2 weeks no problem. The other day it just stopped working. I was trying to play warzone and the pc would restart itself everytime i tried to open the game. I took it to geek squad and they ran all there tests but couldnt figure it out. So im here seeking any advice. Ive been told that it could be the power supply. Or faulty motherboard. Any advice is much appreciated. I just redid thermal pasting i updated gpu cpu drivers. I came across a forum with everybody that had the ryzen 5 5600 experienced the same thing with warzone after an update. They claim to have done a bios update. I don't know how to do that or if that's the right thing to do.
By the way this isnt a problem strictly related to warzone. I downloaded apex legends and smite as well and same result.
My parts are
Ryzen 5 5600
Radeon 6900xt
Zoomflow water cooler
Asus tuf gaming x570 plus wifi
32gb ram.
Gamemax 850w 80+ gold psu.
Thank you for any advice and suggestions.
 
Last edited:
Hey everyone thabk you for your time. So i have a fairly new custom pc. Its not even a month old. I was buying the pieces little by little. Ive been gaming for about 2 weeks no problem. The other day it just stopped working. I was trying to play warzone and the pc would restart itself everytime i tried to open the game. I took it to geek squad and they ran all there tests but couldnt figure it out. So im here seeking any advice. Ive been told that it could be the power supply. Or faulty motherboard. Any advice is much appreciated. I just redid thermal pasting i updated gpu cpu drivers. I came across a forum with everybody that had the ryzen 5 5600 experienced the same thing with warzone after an update. They claim to have done a bios update. I don't know how to do that or if that's the right thing to do.
By the way this isnt a problem strictly related to warzone. I downloaded apex legends and smite as well and same result.
My parts are
Ryzen 5 5600
Radeon 6900xt
Zoomflow water cooler
Asus tuf gaming x570 plus wifi
32gb ram.
Gamemax 850w 80+ gold psu.
Thank you for any advice and suggestions.
Please run userbenchmark and post a link to your results
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

That PSU is not something I'd call a reliably built unit, FYI. The issue with a system reboot when taxed, is either due to a thermal issue(overheating) or that the PSU can't deliver the necessary power to the entire system. You might want to rule out a faulty PSU by sourcing a donor PSU from a friend or neighbor who owns a reliably built PSU and has at least 800W of power for the entire system.

As for your BIOS concern, what BIOS version are you currently on?
 
May 2, 2021
6
1
15
0
Welcome to the forums, newcomer!

That PSU is not something I'd call a reliably built unit, FYI. The issue with a system reboot when taxed, is either due to a thermal issue(overheating) or that the PSU can't deliver the necessary power to the entire system. You might want to rule out a faulty PSU by sourcing a donor PSU from a friend or neighbor who owns a reliably built PSU and has at least 800W of power for the entire system.

As for your BIOS concern, what BIOS version are you currently on?
Thank you for your input. I was just looking at the bios. And i believe its up to date because the geek squad had to flash it since my ryzen 5 was not compatible with the motherboard. Mostly everybody has said that it must be the power supply. Im going to purchase on right now.
 
Reactions: white.a.drew
May 2, 2021
6
1
15
0
The motherboard wasn't faulty. What processor do you have? I swapped out the motherboard and it did the same thing until i updated my bios then it worked with the new board. So i suggest updating to the latest version of bios.
 
May 2, 2021
6
1
15
0
Yeah dude. Its not easy with that mother board but youll have to do a bios update for it. I switched motherboards but it didnt work until i updated to the most recent. That motherboard wasnt factory made for your chip or mine so you had to flash it to begin with. Just update bios and let me know if it worked for you.
 

ASK THE COMMUNITY

TRENDING THREADS