Question Need help with screen tearing

Jun 9, 2019
44
2
35
0
Hello guys i need some advice on screen tearing on fortnite
These are my specs:
i have a MSI Optix mag27c 144 hz display
GPU GTX 1080 8GB
i7 8700k OC'd at 4.5 ghz 1.2 volts
Mainboard ASUS PRIME z370 p
RAM RIpjaws 2x8 GB
OS Windows 10

I run the game at the lowest settings everything optimized and if i cap the fps at 144 i get huge horizontal screen tearing i tried capping at 140 it gets better but still able to see the tearing
only at 160 fps it almost goes away wich is weird if my display is 144 hz and i play at a higher refresh rate

ive tried everything ive turned this display is freesync/gsync compatible ive tried turning it on it makes no diference still get huge tears even with fast sync it doesnt go away it seems to be worse on fortnite every other game doesnt tear like this only in this game i get performance issues i think that with my specs with would be enough to run it wihtou any problems but i get alot of fps drops my fps goes up to 240 + but sometimes drops to 60 and below very quick i dont know what else to do i dont know if its my system or the display causing this
if anyone can help me with this i would be very apreciated
 
So we have to determine if the tearing is from:
  1. Really high fps. Way higher than the monitors refresh rate.
  2. The FPS dips down to the 60's. (This sounds more likely the cause)
Is your power plan set to high performance in Windows 10 control panel?
What happens if you don't play on the lowest graphical setting? Is there less screen tearing or more screen tearing?
Have you tried making a profile in nvidia control panel for said game and setting your gpu to preferred maximum performance?
What power supply do you have? Please describe the PSU cables connected to the graphics card.
 
Jun 9, 2019
44
2
35
0
So we have to determine if the tearing is from:
  1. Really high fps. Way higher than the monitors refresh rate.
  2. The FPS dips down to the 60's. (This sounds more likely the cause)
Is your power plan set to high performance in Windows 10 control panel?
What happens if you don't play on the lowest graphical setting? Is there less screen tearing or more screen tearing?
Have you tried making a profile in nvidia control panel for said game and setting your gpu to preferred maximum performance?
What power supply do you have? Please describe the PSU cables connected to the graphics card.
yes my power plan is set on high performance , in nvidia also max performance even when im in creative with no fps dips i get the tears everytime i move my mouse , im at the lowest graphical settings possible
my PSU is bequiet straight power 800
and the cables there are 2 pci cables on the gpu also im using DP cable for the display
its very weird ive never experienced somethin like this before i dont know what else to do it only seems to get better at 160 fps wich is higher than the monitor , it makes no sense ...
 
Last edited:
I'd try a higher quality power supply and make sure there's two dedicated psu cables going to the graphciscard. They make those daisy chain cables where you plug two ends into the gpu and the other end into the psu. You can use those, just use two of them. When did it start happening? Did you do a clean install of Windows 10 when you first built that system?
 
Jun 9, 2019
44
2
35
0
it hapenned when i bought this display i used to play on a 60 hz display and never had a screen tear problem in my life even without any kind of sync but since i upgraded it has been hapening

ive reinstalled windows ive done the same to fortnite and still the same , i guess i could try a new PSu when i have the money for it to see if finnaly this goes away because its so anoying playing like that
 
You should definitely have less screen tearing with a higher refresh rate monitor. Double check and make sure your refresh rate is set properly in both your monitor and game settings. Also try using a better quality displayport cable because that type of cable has the best support for high refresh rate. If it is, RMA or return the monitor for something else.

Right click desktop and select advanced display settings > display adapter properties > Monitor Tab
 
Jun 9, 2019
44
2
35
0
ill try to buy a new cable and see if solves it i used 2 diferent ones the one that came with the monitor and one i had laying arround ill buy a new one and see if it makes any diference my hz both in nvidia and on windows display settings are at 144
and sadly i lost the receit for the monitor when moving to a new house so returning it is out the window :/
 
ill try to buy a new cable and see if solves it i used 2 diferent ones the one that came with the monitor and one i had laying arround ill buy a new one and see if it makes any diference my hz both in nvidia and on windows display settings are at 144
and sadly i lost the receit for the monitor when moving to a new house so returning it is out the window :/
Not necessarily. If you purchased it with credit they can look it up and they have other ways around it.
 
Jun 9, 2019
44
2
35
0
i will try the other options if nothing works ill try and return it
also i was wrong about my psu it is 630 w i just had a box from a 800 w laying arround and thought i had that one in this build
 
That's cool, but it's less about the wattage, but quality. I'm more inclined to say it's the monitor, but that's because my friend had a similar issue with a dell 144hz 1440p monitor and he had to return it due to screen tearing.
 
ive tried everything ive turned this display is freesync/gsync compatible ive tried turning it on it makes no diference still get huge tears
Make sure adaptive sync is turned on in both the monitor's menu, as well as in the Nvidia control panel. In the monitor's settings it will likely be referred to as FreeSync, while in the Nvidia control panel it should be referred to as G-Sync, but they are essentially referring to the same thing. See here for a more detailed description of what you need to do...

https://www.tomshardware.com/reviews/how-to-run-gsync-on-freesync-monitor,6072.html

And when adaptive sync is active, you will need to keep your frame rate within the supported range for it to prevent tearing, so probably a 140 fps limit within the game would be a good option.
 
Jun 9, 2019
44
2
35
0
Make sure adaptive sync is turned on in both the monitor's menu, as well as in the Nvidia control panel. In the monitor's settings it will likely be referred to as FreeSync, while in the Nvidia control panel it should be referred to as G-Sync, but they are essentially referring to the same thing. See here for a more detailed description of what you need to do...

https://www.tomshardware.com/reviews/how-to-run-gsync-on-freesync-monitor,6072.html

And when adaptive sync is active, you will need to keep your frame rate within the supported range for it to prevent tearing, so probably a 140 fps limit within the game would be a good option.
ive tried that and it kinda works i get just some little tears here and there but not as bad as before i will play a bit longer with it and see how it goes thank you guys for trying to help
 

ASK THE COMMUNITY