• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

NEW BUILD = LOW FPS

Bradguin121

Distinguished
Nov 29, 2011
15
0
18,510
0
Hey guys,

I recently built myself a new PC mainly for gaming, Here's the spec's:

Intel i5 3570k (Stock Cooler)
HD Radeon 7850
ASRock Z77 Pro4-M Motherboard
8GB Vengeance 1600MHz DDR3 RAM
500GB HDD
Corsair 600W PSU
Windows Vista Ultimate (64-Bit)

I'm getting really low FPS on all my games. For example on Fallout 3 FRAPS says I get:

2012-08-04 10:01:43 - Fallout3
Frames: 871 - Time: 19391ms - Avg: 44.918 - Min: 52 - Max: 65

This with everything Maxed Inc AA @1920x1080.

First of all I dont get it.. How can my Average FPS be 44 when my min is 52? :pt1cable:

I'm using the 12.6 drivers for my Hd 7850, because when I try and download the 12.7 BETA I get the following error:

'the procedure entry point k32enumprocesses could not be located in the dynamic link library kernel32.dll'

...then when i click ok it says 'CCC launcher has stopped working'

All my temps are fine, so I dont know what could be the problem here! :( Tbh, I am abit of a noob when it comes to all this so I need some help!

All I can think of atm is my HDD. Its pretty old, I took it out of my old PC and formatted it and did a clean install of windows vista ultimate, I think the HDD dying because its making a rattling noise pretty much all the time. I dont know if that could be the problem or not.

I also tested my CPU on PassMark and got - 7480 out of 7729. Is this bad? could it be the problem?

Any help will be greatly appreciated!! :)
 

xtreme5

Distinguished
Dec 7, 2011
3,279
0
21,160
127
Everything seems fine but this is the only driver issue custom uninstall the driver from control panel after that run driver sweeper program to remove all the tiny files remaining of the driver remove CCC too. Reboot and install the latest driver.
 
make sure your mb is up to date on the bios code (1.4) there a few bug fixes for that mb. also make sure you have the newest intel chipset driver from intel it newer then the one on the mb cd. make sure your hard drive set to achi mode not ide. also check in the ccc panel if there any power saving settings. if there are turn them off. same for the c states in the bios. turning them off will keep the cpu and gpu from throttling back. also check in the ccc what aaa and monitor set up is if you have one monitor then turn off muilt monitor that give more gpu power to the games. some time in ccc or nvidia aaa can be set to 8 or 16x. or in the game itself. sometime you have to tweek both the gpu settings and game settings.
 

Bradguin121

Distinguished
Nov 29, 2011
15
0
18,510
0


Thanks for all that! :) I'll give all your suggestions a look at tomorrow....well today if you want to be a smart ***. :lol:

I've been looking for a solution for this for a couple of days now, and alot of people have said i need to upgrade from vista to 7 or even just wait for win8 in october. what do you think i should do? because I also forgot to mention my boot up time is pretty slow AND windows can be really slow at times.
 

Bradguin121

Distinguished
Nov 29, 2011
15
0
18,510
0


Will driver cleaner pro do? I got recommended it by someone.
 


Well I would take Windows 8 or even 7 over Vista anyday but I do not think that is the root of your problems just a personal preference. With all the updates to Vista install it is really a good OS. As for the Beta driver remember they are beta so they may have problems with some systems that will not effect the final version of the drivers. The beta drivers installed just fine on my rig but that may not be true for all rigs.
 

Bradguin121

Distinguished
Nov 29, 2011
15
0
18,510
0


Where do I find the BIOS code? I went on my BIOS and all i saw was UEFI Version - P1.00? Is that right, yeah?
 

Bradguin121

Distinguished
Nov 29, 2011
15
0
18,510
0


I dont know how to update my BIOS on my BIOS. I havent seen a update tool in my BIOS at all :/
 

Robbaazz

Honorable
May 20, 2012
138
0
10,710
6

Correct me if I'm wrong, but I think you download the ROM file onto a USB device and set it as your boot prior but that's only for me with an ASUS mobo. :)
 

Robbaazz

Honorable
May 20, 2012
138
0
10,710
6
No only the top 3 ones I think, and yeah CD is fine, just double check the file type, if it is an application you might be able to run it straight from your PC without rebooting and changing priority to CD ROM drive :D
 

Bradguin121

Distinguished
Nov 29, 2011
15
0
18,510
0
According to this video on YTube 'HOW TO UPDATE YOUR UEFI BIOS (Asrock Motherboards - Z77 Extreme4 etc.)' I only need to download instant flash to update my BIOS?
 

Bradguin121

Distinguished
Nov 29, 2011
15
0
18,510
0


Do I disable the following?:

Enhanced Halt State (CIE)
CPU C3 State Support
CPU C6 State Support
Package C State Support

At the moment they're all ENABLED.

Also, what about CPU Thermal Throttling and Hardware Prefetcher? Do they need Disabling?

I disabled IGPU Multi Monitor in my BIOS, Is that ok?
 

Bradguin121

Distinguished
Nov 29, 2011
15
0
18,510
0
updated my bios and its still preforming like it did before....surely its has to be a hardware problem? i cant see another reason
 

obsama1

Distinguished
Feb 3, 2012
3,070
0
21,160
103
Do not disable those unless you are OC'ing. They're very helpful. Make sure all the windows updates, chipset drivers, windows updates are in place, uninstall the AMD drivers, restart, and install the 12.7 beta.
 

Similar threads