New build, unable to display

Aug 9, 2018
2
0
10
0
Hi guys, I've recently ordered new parts in order to upgrade my pc. However I cannot get it to work and I don't have spare parts to test certain components.

New parts:
CPU: AMD Ryzen 2700x
RAM: Vengence 2x8gb ddr4 3000MHz
Motherboard: Gigabyte AB350M Gaming 3
SSD: WD Black 250gb

Old parts(Known to work):
GPU: EVGA GTX 970
PSU: EVGA 650W Gold
CPU Cooler: Seidon 120v
HDD
Monitors + cables
Case cables

[strike]After the initial build, the pc did not turn on when I pressed power button. Once I removed the gpu it powers on however there is no display. [/strike]
I've since replugged the GPU and it powers on fine but still no display.
I tried using VGA, DVI and hdmi (on the motherboard) but nothing worked. The weird part is when I have one ram stick in, the pc would power on, then off, then on again with no display. The fan would also slow down and dim after a few seconds. But when I power on the pc without any ram sticks, the fans wouldn't slow down and dim and wouldn't keep rebooting.

Things I've tried:
Clear CMOS
Reseat cpu, ram, gpu
Tried all ram slots
Clean any dust
Checked connections

I don't have a speaker for the motherboard so I can't listen for the beeps.
Any help would be appreciated :)
 
Often times it is simply due to a cable not being plugged in fully (or forgotten all together).

In your case though the BIOS update is likely as B350 boards where designed for 1st gen Ryzen products, and if the board is not the newest stock from the OEM then it does not have the new BIOS on it to support the new 2nd gen Ryzen CPUs (those that are 2xxx model number).

Go through this write up, and if nothing fixes it, the your issue is most likely the bios: http://www.tomshardware.com/forum/261145-31-perform-steps-posting-post-boot-video-problems
 

ASK THE COMMUNITY

TRENDING THREADS