[SOLVED] New Build Won't Power - Missing CPU_PWR2 cord?

Dec 26, 2018
4
0
10
0
New build won't power. The Corsair CX450 PSU does not come with a CPU_PWR2 cord. The MSI B450 Caming PRO Carbon MB seems to want one. I can't find anywhere whether the PWR2 is necessary (it seems so) or whether the PSU I have just isn't compatible. PC Part Picker did not give any indications of incompatibility.

This is my first build ever so I'm not exactly sure what I'm doing. Please help!
 
Hmm. It seems consistent with either a bad PSU or board but we can't determine what exactly the issue is without testing with other parts. Finding a spare power supply to test with should be easier than locating a board (whether it's from a friend or a local tech or whatever).

In the meantime you can pull out the RAM and CPU, test a bare board just to see if there's any other hint of life.

What kind of graphics card did you plan to use anyway? That system will require some kind of card since current Ryzen chips have no integrated GPU and 450W is a bit light for gaming
 
Generally the PC should start or show some sign of life with only the basic four pin CPU power (without the second four pin set attached). We do need more details like the other poster said. Is there any light or even a hint of a fan spinning?
 
Dec 26, 2018
4
0
10
0
So we have an AMD Ryzen 5 2600 CPU. When you press the power button I can see one (red) LED light up in the corner of the MB. Sometimes there will be a flash of other LEDs light momentarily (Including the red CPU EZ Debug LED) and then nothing. No fans come on. No sign of life. Right now we only have one memory stick in the 2nd slot. No graphics card attached. Just the PSU, MB, CPU, and one memory stick.
 
Hmm. It seems consistent with either a bad PSU or board but we can't determine what exactly the issue is without testing with other parts. Finding a spare power supply to test with should be easier than locating a board (whether it's from a friend or a local tech or whatever).

In the meantime you can pull out the RAM and CPU, test a bare board just to see if there's any other hint of life.

What kind of graphics card did you plan to use anyway? That system will require some kind of card since current Ryzen chips have no integrated GPU and 450W is a bit light for gaming
 
Dec 26, 2018
4
0
10
0
I was thinking about going out to get another PSU. We have an Asus GeForce GTX graphics card.

Get this - even the PSU fan doesn't turn on. Shouldn't it?
 
Does any fan even twitch as though it 'wants' to start?

The PSU fan spins continuously on a working system but on a bad board it might not go anywhere either. The symptoms are suggestive - my first guess would be PSU - but not conclusive on their own.
 
Dec 26, 2018
4
0
10
0
I did a paper clip test on the PSU and the fan will spin when receiving power. When I plug everything into the MB I get nothing. I hear a little click in the PSU and then nothing. No other signs of life other than the red LED on the MB.
 


Try testing the board outside the case, to rule out a short. Leave only the 24 and 8 pin power cables connected. No other wires.
 

ASK THE COMMUNITY

TRENDING THREADS