Question New build won't power on. HELP!

Sep 7, 2019
1
0
10
0
Parts list before we get into the issue:
  • MSI B450M Gaming Plus mobo
  • Ryzen 3 1200 CPU
  • 2x 4 GB Corsair Vengeance LPX 3000 MHz RAM
  • EVGA 3 GB GTX 1060 GPU
  • Crucial P1 NVMe M.2 SSD
  • Corsair CX450M PSU
Whole rig clocked in somewhere in the neighbourhood of 260 W on PCPartPicker.

Tried to build this when I got the parts a couple of weeks ago but the mobo was wack. It could boot and do everything just fine, but the screen would periodically blink black, and eventually it would freeze and need to be reset. After a few days, it shorted out and died entirely. Replacement just came today. I breadboarded it and plugged in a keyboard/mouse/monitor I know are ok. The keyboard and mouse light up when I jump the power (which didn't happen with the old mobo post-short), but none of the fans start spinning. I've unseated and reseated everything, tried every combination of RAM sticks in and out of DDR4 slots. I borrowed a 550 W PSU from a friend that's been proven to work, hooked it up, and it hasn't been doing any better with that.

A potentially relevant detail (but also potentially completely irrelevant and I sound silly, whatever) - the casing around the fan on the CPU heatsink is slightly looser than it was when it came out of the box because I had to jiggle it quite a bit to get the heatsink off the CPU taking it off the old board.

I have already gone through all of the steps in this link and nothing has worked:
https://forums.tomshardware.com/threads/perform-these-steps-before-posting-about-post-boot-no-video-problems.1285536/

Does anybody have any suggestions for what the problem might be, or at the very least which steps to take next?
 

ASK THE COMMUNITY

TRENDING THREADS