Question New build won't start

InToLn

Distinguished
Feb 6, 2013
9
0
18,510
0
Hi. I'm trying to troubleshoot a build. The CPU fan won't turn on. All other fans do (case, gpu). When I try to boot with one ram stick instead of two, I get a three beep error code. I've tried with two different sticks in every slot. It seems like they're not compatible, but I'm pretty sure they are. I'm using a ASRock Z170A-X1/3.1 with G.SKILL Ripjaws V Series 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 2400. Any pointers would be appreciated.
 

InToLn

Distinguished
Feb 6, 2013
9
0
18,510
0
Intel Core i7-7700K Kaby Lake Quad-Core 4.2 GHz LGA 1151 91W BX80677I77700K Desktop Processor

Crucial MX300 2.5" 525GB SATA III 3-D Vertical Internal Solid State Drive (SSD) CT525MX300SSD1

GTX 1080

Seasonic FOCUS GM-750, 750W 80+ Gold, Semi-Modular, Fits All ATX Systems, Fan Control in Silent and Cooling Mode, 7 Year Warranty, Perfect Power Supply for Gaming and Various Application, SSR-750FM

And the RAM/motherboard given in the OP
 

logainofhades

Titan
Moderator
That board requires a bios update, in order to run that CPU. You said this was a new build. Is there any chance you can return the parts for something different? Buying new parts, for a dead platform is not a very good choice.
 

InToLn

Distinguished
Feb 6, 2013
9
0
18,510
0
That board requires a bios update, in order to run that CPU. You said this was a new build. Is there any chance you can return the parts for something different? Buying new parts, for a dead platform is not a very good choice.
I guess that would do it. I'll look into it. Thank you.
 

InToLn

Distinguished
Feb 6, 2013
9
0
18,510
0
I bought a new motherboard because the one I had got ESD damage. Bought some new parts but I was hoping I wouldn't have to get a new CPU.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts