Question New build, worse performances

Dec 1, 2019
6
0
10
0
Hello Guys, i have just built a new pc, my old build was this:
i5 4690k;
Gtx 1070 msi gaming X;
8gb ram dd3 g skill;
Asrock mod 1150 z97;
1 tb WD blue;
2 tb WD green;
Samsung 850 evo 250gb;
XFX P1-650B-BEFX


With this build i could play everything on FULL HD, with high and Ultra settings.
After my mobo's death i have decided to build another pc keeping the hard disks, ssd and GPU and buying these new parts:

Ryzen 5 3600;
MSI B450 Gaming plus MAX;
Crucial ballistix Sport 8x2 gb Single rank 3200mhz;
Corsair TX 650M.

My problem is that the in- game performances are a lot worse than before, on Overwatch with the older build, i could play with everything on Ultra at 60 fps , now, the game can barely keep 60 fps and when there's a lot on screen i get a lot of fps drop, reaching even 40fps.
The witcher 3 is even worse, before i could play at 60 fps with everything on high and even ultra, and now the game can barely keep 30 fps.
I tried everythig, from formatting and reinstalling windows, updating the bios, updating all the drivers, tried older GPU drivers with a clean installation but nothing worked.
I have kept an eye on the temperatures and they are just fine, with 50-60° on the cpu while gaming and 70-75 on the gpu. The task manager is alright, no strange usage peak or anything wrong... At this point i don't know what to do anymore, i really tried everything i could think of, i can't understand why my pc is behaving like this and this doesn't make any sense, if anyone have any insight at all, please tell me!
 
Nov 24, 2019
41
3
35
0
I have a similar issue except I upgraded to a ryzen 5 2600 and an msi b450 tomahawk MAX, where I have frequent driver crashes in video games but it works fine on my older intel board. After extensive research I’ve read that many b450 boards, especially MAX variants, are suffering from bios issues so it might be your motherboard causing this

Getting an x470 chipset motherboard or x570 might remedy this, although for x470 you’ll usually need to flash bios to an updated version for gen 3 ryzen support and for that you’ll usually need a gen 2 ryzen cpu

Or i could be completely wrong. Just throwing thoughts out there
 

ASK THE COMMUNITY

TRENDING THREADS