Question New Builder! Having issues getting a post (Led debug has DRAM light on.)

Sep 12, 2020
Okay so here's my build:

pretty much I've been dealing with an ongoing issue for the last 3 months. trying to get a boot. At first I thought it was the powere supply. Then I thought it was the mother board (3 motherboards later). But this time I made sure to buy one with a debug LED since I'm new. Now it's telling me it's the ram. but I just don't get how it can be the ram.

I've literally not only made sure they were in properly. But I've tried every slot along with buying another pair of the exact same ram repeating the process. (already filing for a return/replacement on the others.)

and it still didn't work, go figure.

But yeah. some notes:
1. Debug LED lights up for DRAM.
~ I've tried 2 sets of ram sticks in every port. it still isn't working I don't think the ram sticks are the direct issue.
2. The phanteks cords make no sense. And Idk what plugs into what. I think I got everything in right except for the fans.
~There is only one fan light that will turn on...can't figure that out.
  1. I've never once gotten a boot/post before.
  2. I've had over 12 friends help me over video that know computers and have built their own. but none of them understand whats wrong.
Feel free to ask for pics, and thank you for any help I can get ahead of time ^^

(And yest I am sad about buying this graphics card months ago. After hearing the next gen wouldn't be that large of an upgrade/too expensive. I thought It wouldn't bother me. Now I sad ^^; r.i.p me )
Sep 12, 2020
Have you cleared the CMOS?
Have you tried booting with only 1 stick of RAM in slot DIMMA2?
Have you tried booting with no drives connected to see if you can get into the BIOS?
Have you tried booting the motherboard outside the case?
No I have not attempted clearing the CMOS yet, I will try that in the morning.
I have tried 1 ram stick in each configuration with 2 sets of sticks.
I only have my m.2 ssd installed, and no I have not tried booting it without it.
I have tried booting it outside the case on earlier builds. though I can't remember if I attempted it with this motherboard.