[SOLVED] New m2 ssd not showing

Sep 8, 2019
2
0
10
1
I bought a new M2 ssd today(transcend 110s), and while it does show up in bios it doesn't show up in windows.
I use windows 7 which I now understand isn't fully compatible with NVME.
I'm not sure if it's because I don't have the correct driver(microsoft deleted the hotfix that I need, I think), and the manufacturer website doesn't have a win 7 driver.
when I enable the m2/optane option in bios the computer refuses to boot, unless I disable it.
Is there anything I can do or is it a lost cause and I need to either get a SATA SSD or uprgrade do windows 10?
Im using the z370-a pro msi motherboard which only has 1 m2 slot.
 
Sep 8, 2019
2
0
10
1
Solved.
This is for people who only want to add an M2 NVME SSD to an already existing Windows 7 installation, not creating a new one.
First download the hotfix released by microsoft(can be found here: https://www.sevenforums.com/drivers/417318-nvme-driver.html )
Simply run the hotfix and restart the computer and driver should download.
However, if you get error 0x80240037, download this: ( https://github.com/zeffy/wufuc/releases/tag/v1.0.1.201 )
After downloading the above 'fix' to windows not allowing win7 updates, the hotfix should work as it did for me.
Simply restart the computer and the driver should then appear as normal.
 
Sep 8, 2019
2
0
10
1
Solved.
This is for people who only want to add an M2 NVME SSD to an already existing Windows 7 installation, not creating a new one.
First download the hotfix released by microsoft(can be found here: https://www.sevenforums.com/drivers/417318-nvme-driver.html )
Simply run the hotfix and restart the computer and driver should download.
However, if you get error 0x80240037, download this: ( https://github.com/zeffy/wufuc/releases/tag/v1.0.1.201 )
After downloading the above 'fix' to windows not allowing win7 updates, the hotfix should work as it did for me.
Simply restart the computer and the driver should then appear as normal.
 

ASK THE COMMUNITY

TRENDING THREADS