New memory not working

Junaid_6

Commendable
Aug 28, 2016
14
0
1,510
0
I bought the following ram

Look at this on eBay http://www.ebay.co.uk/itm/252526262264

My mobo is an Intel dq67sw

I installed the ram in slot 2 and 4, nothing shows on screen.

I installed 1 in 2 and it works (both tried alone in slot 2).

If I switch back to 2x2gb in slot 2 and 4 it's all fine.

Help please D:
 
Read your motherboard manual.
It will direct you to where less than 4 sticks need to be mounted.
Sometimes the slot positions are not obvious.

It is not clear to me that your new ram is compatible.
I do not see it as a listed option on the apacer web site for your motherboard.
http://us.apacer.com/product/memory-search/result/

Sometimes there are bios updates, and ram compatibility is a frequent reason for them.
Be careful if you update the bios, a failed update can brick your motherboard.

Since you have tested each stick and it works ok individually, it is unlikely that the ram is bad.

If you have the option in the bios, try increasing the ram voltage a notch; sometimes that can fix multiple stick issues.
Ram needs to be matched as to characteristics to work properly.
It looks like this is not a single matched kit.

If all else fails, return the ram.
Look for a matched kit that a ram vendor warrants is compatible for your motherboard.
 


The standard for DDR3 ram is 1.5v. You could try 1.52 if that is an option.

The motherboard manual should have instructions on how to update the bios.
It is best to do this outside of a windows environment. Typically with a cd or usb device.
 


Probably a good idea.
Go to a ram vendor web site like Kingston, corsair or g.skil.
Enter your motherboard in their ram selection app and you should get a list of compatible kits.
Then, if there is any problem you will get support.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts