• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question New PC build Gpu fans working but no output from GPU (Aorus Rtx 2070 super)

Jul 10, 2020
5
0
10
0
My GPU fans are spinning but there is no lights or output from the GPU itself. It's a new build. The Gpu worked for 10 seconds on the second slot on my motherboard. But before I could plug in the Display port into my monitor the lights on the GPU stopped again but the fans are spinning. My Motherboard is ROG crosshair Hero VII (X470) chipset. How do I get the GPU to start working?
 
Jul 10, 2020
5
0
10
0
Motherboard: ROG crosshair vii hero (x470 chipset)
CPU: Ryzen 5 3600 x
RAM: G Skill Trident G RGB DDR4 3600 2X8 Gb
GPU: AORUS Rtx 2070 super
PSU: Corsair RM 850i (Gold)
AIO: Corsair H100i
 
Jul 10, 2020
5
0
10
0
The motherboard when purchased it did indicate it was Ryzen 3000 ready. The GPU should light up even if it was not ryzen 3000 ready right? Like the gpu fans work but and the Aorus logo on the fan itself lights up not very bright though, but the overall Gpu on the top and front doesnt light up at all.
Could it be a loose connection within the GPU?
 

DSzymborski

Champion
Moderator
The motherboard when purchased it did indicate it was Ryzen 3000 ready. The GPU should light up even if it was not ryzen 3000 ready right? Like the gpu fans work but and the Aorus logo on the fan itself lights up not very bright though, but the overall Gpu on the top and front doesnt light up at all.
Could it be a loose connection within the GPU?
As in there was a sticker or a notice on the box saying so? This is a very specific thing that updated motherboards have, so please be specific.
 
Jul 10, 2020
5
0
10
0
I meant the website in the description said Ryzen 3000 ready. There is a USB Bios flashback option on the Motherboard, should I try updating Bios through this option?
 

ASK THE COMMUNITY

TRENDING THREADS