Question New setup, USB ports not working, no beep, no post. all lights and fans spin though

Jul 4, 2019
2
0
10
0
Ok so I just built a PC for a friend, and I'm having issues with it posting now, here is a list of the parts :

-MSI Z370 GAMING PLUS LGA 1151(300 SERIES) z370
-GTX 970 (using his old card for budgeting reasons)
-G SKILL TRIDENT Z ROYAL SERIES 16GB (2 X GB) 3200mhz
-Thermaltake 700w power supply
-intel i7 8700

Ok so.....When I first built it, it booted up, posted, everything worked perfectly....I installed all the necessary drivers, and made sure everything was updated. No issues at that point. he used it for about 5-6 hours that day, then he said the computer crashed, and it got stuck in a boot loop. It was the WHOA blue screen, so I couldn't get into BIOS or anything. I tested the ram, it worked in my pc. I tested the GPU, worked in my PC. However, I couldnt test the CPU because the only other motherboard I have doesn't support intel 8 series. But I did some researching and came to the conclusion the MOBO was just a dud. Or so I thought. I got msi to send out another brand new ms z370 motherboard, put everything in it, and it didn't post, didnt beep, not even any of the USB ports would work. So the exact same problem as before. Now I am posting this because I'm fairly certain it has to be the CPU, because that is the only other thing I can think of. Before I send it out for an RMA, could maybe one of you give me some reassurances, or maybe tips on how I could troubleshoot this issue?
-Again, everything is wired properly, I have a minimal hardware setup(GPU,CPU, one ram stick in the correct slot, with mouse and keyboard plugged in.
-I'm using the hdmi out of the GPU, and I know the monitor and the cable works.(I also tried running a display port cable from my monitor directly into my mobo, still no luck.)

If you have any questions about my situation please ask, I will respond as quickly and accurately as I can. Thanks for the time reading
 

ASK THE COMMUNITY

TRENDING THREADS