Question New to pc having trouble optimizing

Jan 5, 2020
3
0
10
0
New to PC gaming and really just having trouble running a few games. I went all out with the build maybe even a little overkill. So i am looking to blast all setting and make it as pretty as possible and as smooth as possible. I was originally thinking i could use the TV below as i already use it for my 4k console gaming and it runs beautiful and no problems... maybe that was my first fault!!!! i have my resolution set at 2560x1440 120hz trough the display setting and NVIDIA control panel. Open to suggestion but really trying to not buy another monitor.
Games i have been running and are running good are Whitcher 3 and that seems to run great! Also Escape from tarkov. Both of those games run around 60fps and there is no complaints. The games im having trouble with are Kingdom come deliverance and The outer Worlds. both of which seems like i could turn the setting down all the way and it still has some sort of lag/screen jumping? AND TO BE HONEST IDK IF IM EVEN CALLING IT THE RIGHT THING!! Its just not smooth! Was trying my best to figure things out through the interwebs on my own before resorting to here. I hope i explained that well enough to get some sort of help or even just a few opinions!!!!
Of course since i'm new idk if i'm missing something or what so thanks for your time!!


System: https://pcpartpicker.com/list/vgx4gJ

T.V.-65" Class Q8FN QLED Smart 4K UHD
 

Lutfij

Titan
Moderator
Which version of Windows 10 are you currently on? We're currently on 1909. You should also make sure you're on the latest BIOS update for your motherboard, then make sure you're on the latest drivers for your GPU. To add, did you manually set the speeds for your ram in BIOS or did you just enable X.M.P?
 
Reactions: Jpmurph00
Jan 5, 2020
3
0
10
0
Which version of Windows 10 are you currently on? We're currently on 1909. You should also make sure you're on the latest BIOS update for your motherboard, then make sure you're on the latest drivers for your GPU. To add, did you manually set the speeds for your ram in BIOS or did you just enable X.M.P?
Everything is updated...i have not manually set anything as i dont want to mess anything up.. thanks for the reply...is it possible to upload video and im just missing it?
 
Jan 5, 2020
3
0
10
0
Which version of Windows 10 are you currently on? We're currently on 1909. You should also make sure you're on the latest BIOS update for your motherboard, then make sure you're on the latest drivers for your GPU. To add, did you manually set the speeds for your ram in BIOS or did you just enable X.M.P?
Hey so I’m playing both those games mentioned( kingdom come and outer worlds) on Xbox game pass. I think that Is the route of all evil. Received code for outer worlds through epic store so downloaded that. Everything runs fine!! So idk what was going on but think I’m just going to avoid the Xbox game pass for pc for awhile. Figured I’d let you know so you can sleep easy tonight. Thanks!!
 

ASK THE COMMUNITY

TRENDING THREADS