Question Newly built PC Flashes fan lights for a millisecond then dies?

hi2011090536

Prominent
Nov 6, 2017
21
0
510
0
Hi, I just finished building a PC for a family member. I went to boot it up and install windows, but all that happened was: It flashes the RBG lights on the CPU cooler for a millisecond and then died. Pressing the power button after that has no effect. I have to flip on then off the PSU switch for it to do that again. I have tried thing mentioned in other threads like: Swapping ram slots, booting without GPU, booting without HDD, checking for loose screws in case, removing any extra standoffs. Yet no luck, I can try to attach a Video if needed but it wont be in a great quality. The current specs for this PC are as listed:

ASUS HB1M- 0PLUS
Corsair HX1000Watt modular PSU
Intel Core i3-4160 (previous was i7-2600k but swapped due to similar issue)
MSI GTX 1060 3GB Dual-Fan
500GB WD HDD
4GB Samsung 12800U RAM (x2)
Old CyberPower case

Any help would be appreciated and I can try to offer any information as needed.
Thanks!
 

hi2011090536

Prominent
Nov 6, 2017
21
0
510
0
Update: I swapped PSUs with my current one out of my PC, similar issue, now the fans will spin and the lights stay on for closer to two seconds rather than the original split second. EVGA 750WATT Fully Modular
 

hi2011090536

Prominent
Nov 6, 2017
21
0
510
0
Well, I feel very dumb for this, I jus fixed it... The culprit was as simple as the power switch, reset button plugs were backwards as in positive on negative, thanks for the help though!
 

ASK THE COMMUNITY

TRENDING THREADS