Question Newly built PC has much worse WiFi connection than other devices ?

Nov 7, 2022
2
0
10
0
I just built a new PC with an MSI Pro B660M-A WIFI motherboard. The PC is giving a lot of network issues. For some background, I live in a dorm in which I previously used a laptop. On ookla, I would get ~20 ms ping with 100 Mbps download. However, the new PC shows ~170 ms ping with only 20-25 Mbps download on the same connection. The connectivity strength is also 1-2 bars compared to max bars on the laptop and on my phone. I can see the same problem when sending a constant ping to 8.8.8.8 which gives almost 600 ms ping. Any fixes?
 

Darkbreeze

Retired Mod
Are you using the same Windows installation you were using on your laptop or did you do a completely new CLEAN install of Windows after building the new system?

Do you have the latest stable motherboard BIOS version installed? What BIOS version is currently installed?

Did you go to the motherboard product page and download, then install, the latest drivers for your board's chipset, network adapters, audio controller, etc.?

Those two things are where you should start.

Is this the DDR4 or DDR5 version of that board?

What are the rest of your FULL hardware specs including exact power supply model?
 
Nov 7, 2022
2
0
10
0
Thanks for your help but I fixed the problem! I hadn't realized that the motherboard came with 2 antennas for connectivity which brings the speed tests back to normal.
 
You are not the first person to post here that did not connect the antenna. Also the case itself makes a huge difference. They tend to be huge chucks of metal that block a lot of the signals.
It can help in those cases to buy short antenna extension cables so the antenna can be placed on top of the case. If it works good for you now then I would not bother changing anything.
 

ASK THE COMMUNITY

TRENDING THREADS