Question No Bios

Apr 3, 2020
2
0
10
0
Hi all. So I built my first PC since middle school. Problem is, I can't get it to go to the bios screen. It keeps showing no input on my tv.
Specs are:
AMD RYZEN 7 2700x
EVGA 600 BR, 80+ bronze 600W power supply
V-Color prism II RAM (2 of them)
MSI GEFORCE rtx 2070
ASRock ATX B450 PRO4 motherboard

So I got the power button, everything lights up, the tv is getting an input (it won't let me select that input if it weren't) but I'm not seeing anything and it says no signal. I just can't figure it out. Any help would be much appreciated.
 
Hi all. So I built my first PC since middle school. Problem is, I can't get it to go to the bios screen. It keeps showing no input on my tv.
Specs are:
AMD RYZEN 7 2700x
EVGA 600 BR, 80+ bronze 600W power supply
V-Color prism II RAM (2 of them)
MSI GEFORCE rtx 2070
ASRock ATX B450 PRO4 motherboard

So I got the power button, everything lights up, the tv is getting an input (it won't let me select that input if it weren't) but I'm not seeing anything and it says no signal. I just can't figure it out. Any help would be much appreciated.
You probably need to update BIOS.
 
Can't even get it to go to that screen though. No display, at all.
Are the fans spinning?
In theory the BIOS doesn't need to be updated... B450 boards support 2nd gen ryzen CPUs out of the box.

Try these troubleshooting steps:

  • Check your cable connections from the PSU again and make sure everything is firmly locked in place.
  • Try running with the bare minimums... 1 RAM module, no storage drives.
  • Reseat your memory modules.
  • Reseat your CPU and CPU cooler. Make sure that the CPU is installed properly... you can very gently wiggle it to check. Also check for any bent pins in the process.
  • Reseat your GPU.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS