Question No display under any circumstances when using iGPU, however, dGPU works


May 17, 2015
I am using a MSI Z390 motherboard paired with a 9900K and a 30 series RTX GPU. This is one of the strangest thing I have ever seen in my many years of computer science.

I have a specific application where I need to use integrated graphics without a dGPU for an operating system. The only problem is integrated graphics refuse to work under ANY circumstances.

I receive absolutely no video output when using the motherboard’s I/O HDMI port. No BIOS, nothing, only "no signal/source." I have tried many different solutions and none of them worked. Even when removing the GPU, integrated graphics still do not work. POST is always successful (with or w/o GPU), everything works fine, no hardware issues at all other than the iGPU "not working" properly. The dGPU however, always works.

I do not think this is a BIOS setting related issue. I am in there pretty often and know each setting very well. The BIOS is MSI Click Bios 5.

Things I have tried:

- Enabling IGD/PEG multi monitor in BIOS which enables output from both iGPU and dGPU

- Enabling IGD only which sets iGPU as primary graphic boot device

- Removing the GPU while using both modes mentioned above

- Removing GPU and clearing CMOS

- Trying various HDMI cables

- Throughly inspecting the motherboard’s I/O ports and surrounding circuitry

- I even tried using different displays for the hell of it

- The BIOS is on the latest firmware

Bad port? Manufacturing issue? User issue? I’m at a lost and ready to chalk this as not happening. I think I’ll grab a VGA cable from work and test if it’s just a bad port. Thank you.