Question No Ethernet connection

OB_1

Prominent
Jan 4, 2020
12
0
510
0
I just got a new motherboard (B550-F gaming(WIFI), Ram (16gb, 3600mhz ballistix), CPU (5600x) and aio (Lian Li galahad). I have set it all up today and straight away i had no internet connection. I have the option to connect wirelessly but my Ethernet cable was plugged in and the lights were on to show it was connected.
 
The most common cause is you forgot to load the motherboard drivers. For some reason you must load the motherboard drivers before the ethernet adapter even appears. In many cases windows will then install a generic ethernet driver and that tends to be ok for most ethernrt ports but if it does not work correctly you could try other drivers.

If you think you have all the drivers try the command

IPCONFIG /all and see what the settings on the ethernet port are.
 

OB_1

Prominent
Jan 4, 2020
12
0
510
0
The most common cause is you forgot to load the motherboard drivers. For some reason you must load the motherboard drivers before the ethernet adapter even appears. In many cases windows will then install a generic ethernet driver and that tends to be ok for most ethernrt ports but if it does not work correctly you could try other drivers.

If you think you have all the drivers try the command

IPCONFIG /all and see what the settings on the ethernet port are.
i havent installed anything for my motherboard. where do i find what i need
 

OB_1

Prominent
Jan 4, 2020
12
0
510
0
The most common cause is you forgot to load the motherboard drivers. For some reason you must load the motherboard drivers before the ethernet adapter even appears. In many cases windows will then install a generic ethernet driver and that tends to be ok for most ethernrt ports but if it does not work correctly you could try other drivers.

If you think you have all the drivers try the command

IPCONFIG /all and see what the settings on the ethernet port are.
Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
 

OB_1

Prominent
Jan 4, 2020
12
0
510
0
On the CD that came with the motherboard. You are doing a clean Windows install, aren't you? A new motherboard usually requires a clean OS install.
yeh i clean installed and i just updated to the latest bios and i still cant connect using ethernet
 

OB_1

Prominent
Jan 4, 2020
12
0
510
0
On the CD that came with the motherboard. You are doing a clean Windows install, aren't you? A new motherboard usually requires a clean OS install.
yeh i clean installed and i just updated to the latest bios and i still cant connect using ethernet
 
It isn't the bios. It is a driver for the motherboard itself. You can download them with a different pc and use a USB stick to load them. If you have a cd in your machine there should have been a driver cd with the motherboard.
 

OB_1

Prominent
Jan 4, 2020
12
0
510
0
It isn't the bios. It is a driver for the motherboard itself. You can download them with a different pc and use a USB stick to load them. If you have a cd in your machine there should have been a driver cd with the motherboard.
there was a cd yeh but i dont have a way of loading hats on it is there nowhere i can get them online ?
 

OB_1

Prominent
Jan 4, 2020
12
0
510
0
There are likely multiple sites the safest site is going to be the mother manufactures site.
ok i installed the chipset driver but there is a few otheres onr for"Intel I225 LAN Driver For Windows 10 64-bit. " and one for "
ntel Wi-Fi Driver V21.70.0.6 for Windows 10 64-bit---(WHQL)."
 

ASK THE COMMUNITY

TRENDING THREADS