Question No image after changing PSU

Page 2 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.
Sep 16, 2020
15
0
10
0
Hello Guys, I have an update...

So, I returned the motherboard, but the store didn't have another one of the same model to send me back, instead they gave me my money back to buy another one. Considering your comments, I decided to get an Asrock B450m Steel Legend, which arrived today.

I put everything back together aaaaand... nothing. I mean, same as before, I ged LEDs and fans rotating, but that's it, no POST screen, no any image signal at all.

By now, to be honest, I just wanted to return everything and give up, I'm THAT frustrated, but I know the reasonable conclusion now is that my problem is the CPU, correct?

I just wanted to check with you if you have any ideas, I'm considering that the new motherboard should be working, which I know is not 100% sure, but seems reasonable to assume.

Anyway, I'll probably RMA the CPU tomorrow, if you have any ideas let me know.

Thank you guys
 

Darkbreeze

Retired Mod
I am still doubtful, in fact, I am ALWAYS doubtful of the CPU being the problem, in EVERY case, unless there has been a power surge, direct strike nearby, bent pins or the CPU has been dropped, OR if it has been an overclocked daily driver for a long period of time, none of which appears to be the case, so I'd have to agree that an RMA of the CPU might be in order, but at this point I'm skeptical of everything so I can't really advise yay or nay on that one.

There certainly doesn't seem to be much else to check. Did you DO the bench test as outlined in the link I provided earlier in the thread or are you still trying to run this in the case?
 
Sep 28, 2020
57
3
35
0
If you have another computer, either your own, siblings, friends. You can swap out parts one at a time and see.

I had a psu problem where it would reboot under load. I swapped my defective psu with my sibling and his computer rebooted underload.

This could take a while, but at least you can narrow down your problem. Make sure you are using the manufacturers cables when plugging everything in, and make sure it's a snug fit.
 

Darkbreeze

Retired Mod
If you have another computer, either your own, siblings, friends. You can swap out parts one at a time and see.
Yes, we/he has/have been doing that since the beginning of this thread. Before this thread actually. Please, READ the thread before posting suggestions. It saves everybody a lot of time and doesn't end up making you look silly for not knowing something has already been done.
 
Sep 16, 2020
15
0
10
0
I am still doubtful, in fact, I am ALWAYS doubtful of the CPU being the problem, in EVERY case, unless there has been a power surge, direct strike nearby, bent pins or the CPU has been dropped, OR if it has been an overclocked daily driver for a long period of time, none of which appears to be the case, so I'd have to agree that an RMA of the CPU might be in order, but at this point I'm skeptical of everything so I can't really advise yay or nay on that one.

There certainly doesn't seem to be much else to check. Did you DO the bench test as outlined in the link I provided earlier in the thread or are you still trying to run this in the case?
Sorry, what bench test do you mean exactly?
 
Sep 16, 2020
15
0
10
0
The one I posted a link to earlier in this thread.

Ok, so, while trying some of the things in the link, something funny happened...

I was testing each RAM stick individually, when I turn it on with one of them, the fans spin normally for 3 to 5 seconds, then their speed drastically reduces, they are still spinning but almost completely silent. When I switched them, the fan keeps going for about 30 seconds as normal, then the whole computer reboots. In neither case I get a POST screen. When turning on with both of them, I get the same 3 to 5 seconds then silent pattern
 

Darkbreeze

Retired Mod
Ok, so if you can't get it to post with NO hard drives attached, nor with either stick of memory installed individually, and you've already tried a different motherboard, and a different power supply, then it has to either be the CPU or the graphics card. Try a different graphics card in THIS motherboard, and try your graphics card in your old system again, just to be sure.
 
Sep 16, 2020
15
0
10
0
Ok, so if you can't get it to post with NO hard drives attached, nor with either stick of memory installed individually, and you've already tried a different motherboard, and a different power supply, then it has to either be the CPU or the graphics card. Try a different graphics card in THIS motherboard, and try your graphics card in your old system again, just to be sure.
Alright, I'll do it tonight

Any idea why I get different behaviors with each RAM stick though? Seems like an important piece of information
 

Turtle Rig

Prominent
BANNED
Jun 23, 2020
772
103
590
13
ANY time there is a power outage, and power returns, there is the possibility of damage from inrush current or surge. Especially on power grids that are not particularly well regulated as in many less developed areas.

So it's always possible for there to be damage to ANY connected hardware after such an event but it is MORE likely that something else is to blame.

Are you SURE you got a new power supply, and didn't simply get the old one back? Did you take it to the store and trade it in for a new, fully sealed replacement unit?

If the answer to that is yes, then ok.

Have you tried the same monitor with the older system, using the same display cable, so that the display and display cable can be eliminated?

If yes, then move on.

You are SURE you are not attempting to connect the display cable to the motherboard output, and are plugging into the graphics card output?

Is there only a lack of display when it tried to boot into Windows, or is there NO DISPLAY/NO SIGNAL at ALL, not even for the POST screen or BIOS?
Nice post guru mod Darkbreeze. Let me add to yoru excellent post. There is one way to be fail safe if you get a power outage and then it comes back on. Usually when it comes on the PC doesn't turn on other things will tho. However my point here is what you can do is use a power conditioner power surge and that will protect you PERIOD. It is costly and your outletes are three prong and no regular 2 pront connection will fit as its small. However your PSU cable and Monitor cable will fit in nice and you can connect some other stuff like expensive studio monitors etc. As for regular power outlet it does not have that but still your monitor and rig are protected. There is no way nothing bad will happen even if magically your PC turns on after a outage and what not. Just thought I add to the darkbreeze mod excellent response.👍✝👶
 

Darkbreeze

Retired Mod
However my point here is what you can do is use a power conditioner power surge and that will protect you PERIOD.
Again, this is completely incorrect. Let me remind you that trying to give people a pat on the back at the same time you are posting wrong and inaccurate information, isn't going to earn you any points, and is still just as likely to get you warned or sanctioned.

Let me clarify THIS one for you. There is nothing, at all, that will 100% protect you from surges or direct strikes on the nearby power node. Nothing. Even a whole house protection unit with a properly earthed circuit is probably not going to protect from a direct strike. It probably WILL protect from a grid surge IF it's not a terribly huge one.

But as far as the surge protection that comes in any kind of power line conditioner, or even stand alone surge protectors are concerned, there are none, ZERO, that offer reliable enough protection to say "that will protect you PERIOD", so to say that you are ill informed in this area and should probably not offer advice about the subject matter so you don't end up giving somebody bad or wrong ideas.
 

USAFRet

Titan
Moderator
Mar 16, 2013
131,243
5,653
165,040
20,208
Nice post guru mod Darkbreeze. Let me add to yoru excellent post. There is one way to be fail safe if you get a power outage and then it comes back on. Usually when it comes on the PC doesn't turn on other things will tho. However my point here is what you can do is use a power conditioner power surge and that will protect you PERIOD. It is costly and your outletes are three prong and no regular 2 pront connection will fit as its small. However your PSU cable and Monitor cable will fit in nice and you can connect some other stuff like expensive studio monitors etc. As for regular power outlet it does not have that but still your monitor and rig are protected. There is no way nothing bad will happen even if magically your PC turns on after a outage and what not. Just thought I add to the darkbreeze mod excellent response.👍✝👶
No.

From a recent close by lightning strike a couple of months ago.

Conditions before:
CyberPower UPS:
HTPC
HP printer
Denon AV receiver
TV
Surveillance camera DVR
QNAP NAS

Triplite USP:
Main PC
Monitors
3D printer

Small Cyberpower UPS:
Other PC and monitors

Main PC and other things on at least 2 different ethernet switches, all going back to the same router.

BAM, lightning strike, close by.
Systems flickered, and came back up. Mostly.

----------------------------
Casualities:
Main PC - ethernet port
HP Printer - ethernet port
Denon receiver - 2x HDMI ports. The TV and HTPC those HDMI cables were connected to were unaffected.
Unplugged Invisible Fence PCB in the garage. Yes...it was literally unplugged from the wall. Blew the cover off, knocked it halfway across the garage.

Again, all the devices except the Invisible Fence thing were running on good quality USBs.

Lightning can do weird things, and follow weird paths.
 
Sep 16, 2020
15
0
10
0
Hey guys, just to let you know, I got my new CPU today, built it up, and IT WORKS! A-***-MEN

Almost 2 months of struggle, pretty much convinced to never build a pc again, but I wouldn't have done it without your help, thank you very much guys!
 

ASK THE COMMUNITY

TRENDING THREADS