[SOLVED] No Power to Monitor, Keyboard, and Mouse After New GPU, Problem Persists Even With Original GPU

Jun 14, 2020
3
0
10
0
Recently I installed a new GPU (Nvidia GTX 1660 Super) to replace my old GPU (NVIDIA GeForce GTX 760) which had stopped working. During this upgrade I also installed 2x4GB of Neo Forza DDR3 ram, to combine with our already installed 2x4GB of Ballistix DDR3 ram. When I powered on the PC, all the fans and components of the PC were running, but the monitor, keyboard, and mouse all did not receive power. I then tried to run the PC both with no GPU and with the old GPU, and the problem persisted. I would really appreciate any assistance!

SPECS
CPU: AMD FX 8350
GPU: Nvidia GTX 1660 Super originally, then tried NVIDIA GeForce GTX 760
Motherboard: Asus M5A97 LE R2.0
Power Supply: Corsair CX600m
Memory: 2x4GB of Neo Forza DDR3 ram, 2x4GB of Ballistix DDR3 ram
 
Jun 14, 2020
16
0
10
2
Try to reset the BIOS by removing the C-mos battery and let it like that for 10-30 mins. Also when u did those changes, did u wear rubber gloves or anti static bracelet or just normal hand without any kind of protection ?
 
Jun 14, 2020
16
0
10
2
Try to reset the BIOS by removing the C-mos battery and let it like that for 10-30 mins. Also when u did those changes, did u wear rubber gloves or anti static bracelet or just normal hand without any kind of protection ?
 
Jun 14, 2020
16
0
10
2
That's great... but for the future I suggest u to wear rubber gloves or antistatic bracelet... trust me... I burned my motherboard twice cuz I didn't wear those
 

ASK THE COMMUNITY

TRENDING THREADS