Question No signal detected while gaming

Jul 20, 2020
2
0
10
0
Hi,

About a week ago when I was playing CSGO my monitor suddenly turned black and displayed message No signal detected. So I used the power button to turn it off and then turned it back on again. Despite that, my display remained in no signal detected mode. I thought It would be a good idea to clean the PC inside, replace the thermal paste on CPU and GPU. After that I was able to boot up my PC and surf the internet for hours until I launched CSGO again and played for like 10 mins, the same thing happened. So I started to test everything, update drivers, clean RAM sticks but none of that has helped. I have also tried doing a 1 hour GPU stress test that ran smoothly and didn't crash my display or anything. For some reason, my display cuts off and PC remains on and I can still hear the sound and keyboard is taking input. That happens every single time. I'd like to point The GPU and CPU temperatures are fine and rarely go above 65 degrees. My PC is 5 years old.

Any idea what could cause that issue? Thanks in advance.

My specs are below:
 
Jul 20, 2020
2
0
10
0
PSU EVGA 500B 500W.

Actually its just happened for the first time while browsing the internet. I turned off the pc using power supply, tuned back on and could hear the fans going full speed but monitor was completely off. Had to turn the pc off again, wait for a while and its booted up to the desktop and same thing happened again.

EDIT I think the issue is caused by GPU as PC is working fine on integrated graphics...
 
Last edited:

ASK THE COMMUNITY