Question NTFS Permissions Issue

Jun 1, 2020
2
0
10
0
I have an internal drive that I want to restrict so that only administrators can access it. Previously in Windows 7 I've done this by giving the administrator group 'Full Control' and removing all other users/groups except the SYSTEM account.

However, when I've done the same thing in Windows 10 I can't view the contents of the drive. My user account is in the Administrators group, and I am able to still access the properties of the drive, change the security, etc. but I can't view the contents. The only way I can view the contents is to give my own user account permissions, but this defeats the object of what I'm trying to do.

I tried creating a new user group, adding my user account to it, then I gave that group 'Full Control' for the drive, but I still could not view the contents.

I've checked the ownership of the drive and my account is set as the owner.

I've tried running explorer as admin, but this made no difference.

I also tried copying the contents to another location, re-formatting the drive, then copying the contents back, but still no joy.

Am I missing something here and have the way permissions work changed in Windows 10? or is this more likely some kind of fault?

Thanks
 

ASK THE COMMUNITY

TRENDING THREADS