Nvidia driver trouble in ubuntu 8.10


Aug 23, 2008
ok i am dual booting vista and ubuntu. ubuntu is on a 100gb partition and vista has the rest of the drive (380 gigs or so). i am using 2x 8800gts in sli. i wanted to use the visual effects of ubuntu for fun so i tried to turn them on. i was required to enable graphics driver. i did and it downloaded and installed version 179.xx i dont remember exactly. :na: it said i needed to reboot for the changes to take place. i did. but when it booted, i got the ubuntu loading orange bar and then it goes into a login shell and i can login but only with text. i can type commands but cant get into any sort of desktop environment. i figured i would try again. i used vista to copy the whole ubuntu partition to an external drive and then wipe the partition. i reinstalled ubuntu and tried manually installing a newer version of drivers, 180.43, with enVy. when i restarted, it did the same thing. :fou: what is happening here? i tried removing one gpu and did the whole darn process over again (incase it was because of no sli support) and the same thing happened. maybe the login shell is a good thing? it means that i can boot but not get into my desktop environment?

computer specs: (just incase)
asus m3n72-d mobo
phenom 9850 OC 2.83ghz
2x 8800gts sli
4gb ddr2 800mhz


Dec 18, 2005
Try Fedora with the proprietary driver from rpm-fusion :)

Both Ubuntu and Fedora are very good, I recommend using both.

Fedora sometimes works on hardware Ubuntu doesn't and vice versa.

GL :)


Dec 28, 2007
What happens if you type startx at the command prompt, is should start the graphics server and then the desk-top; if you get a blank screen, alt-ctl-backspace should get you back to the command prompt.
Sounds more like what happens when the NVida module isn't loaded. Used to happen to me all the time with earlier versions of Gentoo and Fedora. I'm not familiar with Ubuntu.

If that's the case then "startx" will make the screen flash a few times and then return you to the console with the X error messages showing.

If I was the OP I would try downloading the driver from NVidia and installing it manually.

David Gill

Jan 15, 2009
Well, i had the same problem with my 9600GT, what i did was.... I never installed the drivers again because i found myself reinstalling ubuntu 5 times in a space of two days. I don't need them anyway, because i game on vista and do programming on ubuntu.


Mar 7, 2009
Switching distros because you cant get something to work at first will never enable you to learn and become more proficient at using Linux. Here is a solution that worked for me.

You need to specify the busid of the card that is hooked up to your monitor in the xorg.conf device section.



note the bus id for each video card. they look like 02:00:0 or the such. Then drop the extra 0's. Mine is 2:0:0 for one and 7:0:0 for the other.

then type

sudo nano /etc/X11/xorg.conf

and get ready to edit the "Device" section. You will be adding a line that looks like this..

BusID "x:0:0"

X represents your value gleamed from lspci

My device section looks like this

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "2:0:0"

Then after the editing is done, and you MUST make sure there are NO TYPOS, then hit control-x and it will ask you if you want to save the file. Hit y for yes and then enter to accept the file name/location and you should be back at a command prompt.



if it still fails then go back in and edit the file to represent the other busID you got for your second card.

one or the other should get you to a desktop.

If you screw the file up and cant fix it then type

sudo nvidia-xconfig

and then start from the top of this post again.

Note: This worked for me but enabling SLI after totaly broke X again.

Similar threads