Question Old Graphics Card Not Working in a New Build...

Dec 4, 2021
5
1
15
0
I just modernized my computer.

The old system (eventually going to be a hand-me down):
Processor: i5-7500
Motherboard: ASUS H110
RAM: 16 GB G. Skill 2133
PSU: EVGA 600W Bronze Semi-Modular
Graphics: XFX RX 470
Storage: Samsung 1TB SSD and a WD 1TB Hard Drive

The new system contains the following:
Processor: i3-12100
Motherboard: Gigabyte H610 S2H
RAM: 16 GB G. Skill 3200
PSU: EVGA 750W Gold Semi-Modular
Graphics: XFX RX 470 (hopefully)
Storage: WD 1TB M.2 stick and a Teams Group 1TB SSD
OS: Still Windows 10

I decided to save some money and use my old graphics card for now. I put it all together, and it worked great for a day. On the second day, the screen went blank after an hour, and I haven't been able to make it work with the GPU since. These are my troubleshooting steps:

  1. With the graphics card, the system boots, but no display.
  2. Take out the graphics card; the system works great.
  3. Put the graphics card back in the old system, the old system works great.
  4. I thought it might be a bad PSU, so I tried the old PSU in the new system; the system does not even boot.
  5. I take out the graphics card with the old PSU in the new system; the system works great.
Right now, the old system has the graphics card, and the new system does not. Both computers are running fine. Because of the way it responds with the different PSUs, I want to say it's a power draw issue of some kind. Both of my computers are efficiency builds though, and I would think either of these PSUs should be able to handle the load. Do the current generation motherboards and/or the higher frequency RAM draw that much more electricity?

I seek the collective wisdom and experience of this forum. Am I on the right track? What else might I be missing?
 
Dec 4, 2021
5
1
15
0
Well, I tried a different cord. At the same time, I uninstalled the AMD drivers and let the machine detect the graphics card from scratch. Between those two things, it seems to be working again. Hopefully, it stays working.

Thank you for your input.
 

ASK THE COMMUNITY

TRENDING THREADS