Old IDE drive unable to assign drive letter

photodave

Distinguished
May 23, 2011
14
0
18,510
0
Thank you all in advance for your help.

I came across 2 old IDE drives that I wanted to see what was on them, then wipe them before throwing them out.

One is a WDCaviar (WD800) the other is an IBM Deskstar 20Gb.

I am using Win 7 Pro 64 bit and CablesToGo USB to IDE Adapter to connect and give power.

Both drives show up the Disk Management, but when I try to assign a drive letter, the menu is greyed out except for Delete Volume and Help.

Using Diskpart I can see the disk being online but again cannot assign a drive letter.

Below are the details for the Western Digital IDE drive.

Your help is greatly appreciated.

Thank you all.

Old Western Digital IDE drive
Shows up in Disk Management as 73.11 GB Healthy (Active, Primary Partition) and 1.42 GB Healthy (Primary Partition), but right clicking to assign drive letter the menu is greyed out.

Tried to use Diskpart

List disk shows
Disk 0 Online 465 GB
Disk 1 Online 1863 GB
Disk 2 Online 74 GB

Selected Disk 2
Disk 2 is now the selected Disk
Assign (and Assign=f)
There is now volume specified
Please select a volume and try again

Doing List volume
Volume 0 D DVD-ROM 0 B no Media
Volume 1 NTFS Partition 100 MB Healthy System
Volume 2 C NTFS Partition 465 GB Healthy Boot
Volume 3 E New Volume NTFS Partition 1863 GB Healthy

While Disk Manager shows

Disk 0 Basic 465.76GB Online 100MB Healthy System C: 465.gg NTFS Healthy Boot, page, etc.
Disk 1 Basic 1863.02GB Online E: 1863.01 NTFS Healthy Primary Partion
Disk 2 Basic 74.53 GB Online No Dirve Letter 73.11GB (Healthy Active Priamry PArtition)
and No Drive Letter 1.42 Healthy Primary Partion










 
A few years ago I tried connecting an old IDE drive and it never worked properly. If you plan on destroying them, then a hammer drilling holes through them does a good job. I took mine apart and recycled all metal after damaging the platters.
 

noidea_77

Distinguished

And that's not working why?
 
Hi

Have you checked if this ata / ide drive is jumpered as master or slave?
This may affect how the usb to ide bridge works

It should be set to master, usually no jumper on hard drive but look up details at WD site

Try booting off a live Linux cd or usb such as Gparted
If drive was from a TV recorder or Linux PC windows would not be able to allocate a drive letter

Western digital bootable diagnostic disk would probably do an erase format on them or use a dban disk destroyer cd

But disconnect other hard drives to avoid wiping wrong hard drive

Regards
Mike Barnes


 

photodave

Distinguished
May 23, 2011
14
0
18,510
0
Yes, I did check the jumper. There is a diagram on the hard drive itself, and I did try it as Master, Slave, and Master with Slave present, and the forth called Cable Select.

All do show up in the Disk Management screen as "Healthy" but with no Drive Letter that I cannot assign.

I believe this drive might have been part of an external hard drive whose power supply had failed, and I took it out years ago with the intention of checking its contents and then wiping it.

Still hoping I might be able to get my computer to assign a letter and read the drive.

Thank you all again for your thoughts and ideas.
 

photodave

Distinguished
May 23, 2011
14
0
18,510
0
I tried DMDE and double clicked the partition called Primary (A) and it did give me a file/folder structure.

An image (? a disk) called $Noname 01 and under it is $Root.

Under $Root are various other folders: lost+found, var, etc, media, bin, boot, dev, etc.

When I try and open any of these folders, they seem to be empty.

I am not familiar with DMDE and am not sure how to proceed from here.

This is certainly an interesting learning experience for me.

Thanking you again in advance.
 
Hi

That looks like a Linux Unix set of folders and file system

With Windows you get
\windows
\Program Files
\Users or \Documents and Settings\

You can get drivers to make EXT2, EXT3 & similar UNIX file systems visible to Windows

or boot the PC from a Live Linux CD such as gparted.
It can read most Unix disk formats as well as Windows NTFS & FAT32 etc
The Disk Explorer will show the files on the Linux hard drive.

If there are a lot of video files in the media folder it probably came from a TV recorder or similar

regards
Mike Barnes
 

photodave

Distinguished
May 23, 2011
14
0
18,510
0
Thank you!

It seems your Linux Reader was what I needed.

I was able to get into the hard drive and be sure that I did not have any important files. Nothing that I did not have but I did experiment to see if I could recover some data and I could.

My last question .....

If I ran DBAN (Dirk's Boot and Nuke), will it SEE this hard drive so that I can wipe it before getting rid of it? And if not, what would you suggest.

Thank you again
 
I've never had to use DBAN, but AFAICT it runs under DOS and would therefore require that an appropriate USB mass storage driver be installed before it could see a USB drive. Even then, the documentation isn't clear as to whether such devices are targeted by DBAN. Perhaps someone else could answer your question.

That said, ISTM that you could boot to any Linux Live CD and use dd to zero-fill your drive. You would need to be careful that you were targeting the correct drive, though.

dd if=/dev/zero of=/dev/ice

Replace "ice" with your device name, eg "hda".

I would disconnect all your other drives as a precaution.

 

Similar threads


ASK THE COMMUNITY