• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question One PCI port, the computers turn on, two the pc dosent turn on

Jul 23, 2021
15
0
10
0
I just purchased a new graphics card to replace my gtx 760, i purchased a EVGA 1080 FTW, the 760 would use one PCI port, but the 1080 has two, when i plug in the 1st one and i boot, the computer boots on fans an all but tells me to plug in the rest the other pci port, but when i do the computer just dosent get any power at all, and if for some reason the first time it will turn the fan off for 1second then stop,

specs :
motherboard :B450M DS3H
CPU: AMD Ryzen 3 3100 4 cores
GPU : 760 currently in, and the evga 1080 that i want to plug in
psu : ocz700mxsp [700w power supply]
 
Jul 23, 2021
15
0
10
0
update : i can plug in 1 6+2 and 1 6 without the two and the computer turns on, with the display saying i need to plug in the PCI' coords, then when i plug in the the +2 of the last 6+2 it doesnt turn on
 
I suspect the psu can not deliver advertised power.
Perhaps because it is old.
A tier 5 unit on this quality list:

Your EVGA GTX1080FTW is a highly overclocked version that is going to need lots of power.

Can you test with a known good psu of sufficient power?
 
Jul 23, 2021
15
0
10
0
I suspect the psu can not deliver advertised power.
Perhaps because it is old.
A tier 5 unit on this quality list:

Your EVGA GTX1080FTW is a highly overclocked version that is going to need lots of power.

Can you test with a known good psu of sufficient power?
i do not have another one at the current momment
 

ASK THE COMMUNITY