Question Only half of my ram is usable 16/32gb

Sep 13, 2019
1
0
10
0
PC SPECS
CPU: Ryzen 2600x no OC
MB: ASrock b450 pro4
Ram: Hyperx Fury 2400mz CL15 8gb x 4 (32gb total)
GPU: RX 5700 XT
PSU: Enough
Album of Screenshots: View: https://imgur.com/a/qeoLNVd

Task Manager: View: https://imgur.com/a/DRl0ZOK

Ram benchmark result at the bottom: https://www.userbenchmark.com/UserRun/20109653
Problem:
Hello, when I bought the PC I had 8gb of ram, later I add 8 of exactly the same ram and they ran perfectly fine in 16gb dual channel. Yesterday I bought 16 more gb of ram (2x8) with exatcly the same specs. At first pc would only boot with 1-3 ram sticks but would not boot with 4, I tested all the ram sticks in different sockets and they all work fine, even in dual channel. I updated bios to version 1.80 and it worked, I was able to boot with 4 sticks of ram at the same time but now I have the issue that only half of my ram is usable but all of 32gb is detected. I was thinking to update my bios to 3.1 but I saw this thread here and the guy said that the newer versions of bios are all messed up and to not update further from my 1.80. Any ideas about what should I do?
I tried
-Each ram stick in ram slot A1, all worked
-clearing CMOS
-Each ram slot with 2 ram sticks, all worked with 16gb avaliable and dual channel.
-rest bios settings
-updating bios to 1.80
-memtest86, what it detected was fine
-praying, didn't help
-beging for help, in progress...
 

Darkbreeze

Titan
Moderator
Using mixed memory is never a guarantee of success even when you buy "the same model". Unless they came in ONE package, TOGETHER, there really IS NO "same model" because unless you are lucky the chances always exist for there to be differences between two different sticks that didn't come together and when you've done it not just once, but twice, so you have THREE different additions of memory, the chances just go downhill from there ESPECIALLY when you are running four DIMMs.

My primary recommendation would be that you return or sell the memory you have now and buy ONE kit, with two DIMMs that equal the amount of memory you wish to run. THAT is the best way to get what you want. If that is not possible, then your next best option would be to start by doing a hard reset of the BIOS so that the memory will be fully RE-trained.

Power off the unit, switch the PSU off and unplug the PSU cord from either the wall or the power supply.

Remove the motherboard CMOS battery for five minutes. In some cases it may be necessary to remove the graphics card to access the CMOS battery.

During that five minutes, press the power button on the case for 30 seconds. After the five minutes is up, reinstall the CMOS battery making sure to insert it with the correct side up just as it came out.

If you had to remove the graphics card you can now reinstall it, but remember to reconnect your power cables if there were any attached to it as well as your display cable.

Now, plug the power supply cable back in, switch the PSU back on and power up the system. It should display the POST screen and the options to enter CMOS/BIOS setup. Enter the bios setup program and reconfigure the boot settings for either the Windows boot manager or for legacy systems, the drive your OS is installed on if necessary.

Save settings and exit. If the system will POST and boot then you can move forward from there including going back into the bios and configuring any other custom settings you may need to configure such as Memory XMP profile settings, custom fan profile settings or other specific settings you may have previously had configured that were wiped out by resetting the CMOS.

In some cases it may be necessary when you go into the BIOS after a reset, to load the Optimal default or Default values and then save settings, to actually get the hardware tables to reset in the boot manager.



It is also LIKELY that you will need to ADD voltage in order to get four sticks to run. Try adding memory (DRAM) voltage in small increments, .005-.020v steps, saving between each step and then trying to POST and see if all the memory is recognized, until it either IS all recognized and available OR you reach 1.4v. By the time you reach 1.4v you would have reached stability if a lack of voltage at that the speed of your kit, was the problem.
 

ASK THE COMMUNITY

TRENDING THREADS