Overwatch crashing on startup

Avacadoee

Commendable
Jun 5, 2017
53
0
1,640
2
I honestly don't know what to do anymore, I've tried basically everything I could find on the net and nothing has worked thus far, I recently installed Overwatch on a new computer just to play it again as I was soo in love with the game like a year back, but lookie here, crash on startup, like literally doesn't even try starting the game or anything, just crashes, blackscreen, then wabam closed. I've tried running the game in windowed mode on startup properties, I tried uninstalling Razor SDK which was the main cause of problem of many people. One of the first things I did was reinstall and look for repair in Blizzard app, I also tried reinstalling it on a different drive.


Specs: https://pcpartpicker.com/list/q9zh3b
 

jossrik

Distinguished
Don't fear yet... You can try going to the executable in file explorer and running it in admin mode, also, windows 7 compatibility mode. Rhrmm... changing the size of your mouse pointer could be an issue... Lotsa little things that go wrong with Blizz games... They try, they really do, but man, they're so afraid of people cheating that you gotta have everything straightforward. Might need to turn SLI off or on depending on what you're using... Make sure your monitors are set to the correct/same resolution/refresh... And then there are settings in Nvidia Control Panel to play with....
 

Avacadoee

Commendable
Jun 5, 2017
53
0
1,640
2


So I did do the admin mode and Windows 7 compatibility mode, didn't try mouse pointer, not sure what that would do but I tried turning SLI Off and on and still same thing and everything is in their native resolution/refresh rate...
 

jossrik

Distinguished
restarted the computer maybe... After that much, Kinda grasping at straws... Might be conflicting with other startup programs, not just The Razer SDK. I know overlays can sometimes cause problems...
 

Avacadoee

Commendable
Jun 5, 2017
53
0
1,640
2


I did restart the computer, maybe 3 times now, and I know I dont have any overlays on it,, should I run windows on safe mode for no startups and see what happens?
 

Avacadoee

Commendable
Jun 5, 2017
53
0
1,640
2


I dont know what I did but I just deleted a .dll in the games directory and ran the game, It obviously didnt work and tried deleting the other .dll instead to see if that was the problem, it wasn't, I tried running the game after I did that and, for some reason it worked, I don't know why, I guess it corrected itself or something but, it works now. I also opened it as a shortcut and in the properties of the shortcut I put it as minimized, the problem happened again but I did that and it worked...
 

ASK THE COMMUNITY

TRENDING THREADS