Question PC boots but no display and no USB functionality ?

Apr 17, 2022
2
0
10
0
Needing some massive help ASAP.

I tried to update my Acer Predator G3620 from Windows 8.1 to Windows 10, because the updates the wanted to install (shutdown and update) never were installed, it always failed and reverted changes. This was really a pain, and decided to update the OS to Windows 10. I did successfully got to boot via USB (rufus) but the installation stopped at ~27% and then reverted changes. I then proceeded to do a factory reset of the system, this took me back to Windows 8, the OS it came with.

I then went onto changing the boot priority in the BIOS, so that the USB boot was 1st and the HDD was 2nd. This failed, so I reverted changes by going back into the BIOS and change the boot priority from USB 1st to HDD as 1st. In doing so, the BIOS system froze, completely unresponsive. I had to force shut down by holding the power button, now, the system boots up but the is no display (already tried different monitors)(but the monitor detects power (from the PC I'm assuming)), USB functionality doesn't work yet power goes to the USB ports (indicated by my USB drive) or even beep codes (single beep always happened before the update to windows 10 began).
I have reseated the CPU, RAM and GPU, with no success.

I am needing urgent help as this is the only PC/computer I can use to run the programs I need for work (the laptop I'm using now for these forums easily can but it isn't a viable solution).

Acer Predator G3620
Windows 8 or 8.1
i7-3770
GTX660 1.5GB
12GB DDR3 RAM
2TB HDD
CD Drive

I really appreciate your time. I will answer responses as best as possible.
Cheers.

EDIT: I have reset the CMOS, via button battery removal and via the jumper (CLR_CMOS), many times
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS