Question PC boots fans run however no display

Oct 10, 2022
2
0
10
0
Hello,

I had a build from 2 years ago that recently started to freeze in the login screen, or if i was able to login to my computer it would freeze randomly causing me to manually shut off by the power button etc. This occurred around the same time i heard intermittent clicking noise from my power supply. This was my build

NZXT H510
CRUCIAL 16 GB 8X2 D4
AMD RYZEN 2700X WRATHP
GIGABYTE RTX 2070
EVGA 650 W SUPERNOVA GOLD
ASUS TUF B450MPLUS GAMING

after issues occurred and after searching online/asking friends i came to the conclusion that my PSU was faulty as that was the source of the noise. I got a new PSU along with a new case for a smaller form factor however now after i plug everything into the new case with a new PSU PC will not post. My display stays off "no signal" messages pop up. I've tried reseting the BIOS along with cleaning the ram sticks. When the power button is pressed all the fans are on (case fan/cpu fans/gpu fans) however no post. I've used new cables as i bought a new PSU unit and have double checked everything. I am out of ideas and any help would be great. Below is the new build (*** marking the new parts)

LIANLI LANCOOL 170M BLACK
CRUCIAL 16 GB 8X2 D4
AMD RYZEN 2700X WRATHP
GIGABYTE RTX 2070
ASUS STRIX 650W GOLD
ASUS TUF B450MPLUS GAMING
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Did you breadboard your build, prior to dropping them into the Lian-Li case? Rams populating slots A2 and B2 as stated in the manual?

along with cleaning the ram sticks
Can you elaborate on how you cleaned the sticks of ram?

I've used new cables
Sleeved extensions or custom length cables?

You could try and flash your BIOS using the Asus CrashFree BIOS 3 function, as stated in your manual, page 2-1(you have to scan the QR code with your phone), with the latest BIOS version listed on Asus support site.
 
Oct 10, 2022
2
0
10
0
Welcome to the forums, newcomer!

Did you breadboard your build, prior to dropping them into the Lian-Li case? Rams populating slots A2 and B2 as stated in the manual?

along with cleaning the ram sticks
Can you elaborate on how you cleaned the sticks of ram?

I've used new cables
Sleeved extensions or custom length cables?

You could try and flash your BIOS using the Asus CrashFree BIOS 3 function, as stated in your manual, page 2-1(you have to scan the QR code with your phone), with the latest BIOS version listed on Asus support site.
Hello,

thanks for replying 😊

I did not breadboard the build prior to putting it in the new case…

the rams are placed in the A2 and B2 slots I’ve moved them back and forth as well.

As far as cleaning the ram I’ e seen people using erasers and cleaning the ram that way i made sure no residue was left over.

also used the new cables with the PSU so the factory cables that came with the new ROG STRIK PSU

i manually pulled the battery out of my mother board for 5 minutes as i cant access the BIOS as its not displaying anything when plugged in
 

ASK THE COMMUNITY