Question PC Build Not Booting

Aug 8, 2021
4
0
10
0
I am unable to boot my PC following a failure and the replacement of three key components: Motherboard, CPU & PSU.

The LED lights are all on the motherboard. When I press the power button the case fans and the CPU fan briefly spin but that is as far as it goes.
I have been through the new build start up problem guide and tried all the steps.

The board details are: 630117 - 00455 - MB1180 - B04 1405

Current Setup
CPU: AMD Ryzen 7 3700X (brand new)
CPU Heatsink/Fan: Cryorig H7 49 CFM CPU Cooler Single Tower Heatsink with 120mm Fan
Motherboard: A Asus Tuf Gaming X570 plus (brand new)
Ram: 16GB (2x8GB) Corsair Vengeance LPX 3000MHz DDR4-3000 Memory
SSD/HDD: Samsung 860 Evo MZ-76E1T0B/EU 1 TB
GPU: XFX Radeon R9 270
PSU: Corsair RM850 (brand new)
Chassis: Nanoxia Deep Silence 5 Rev. B Case - Anthracite Full Tower Case


Previous Setup
CPU: AMD Ryzen 5 1600 3.2 GHz 6 Core AM4 CPU/Processor
CPU Heatsink/Fan: Cryorig H7 49 CFM CPU Cooler Single Tower Heatsink with 120mm Fan
Motherboard: ASRock X370 Taichi AMD X370 S AM4 DDR4 SATA3 ATX
Ram: 16GB (2x8GB) Corsair Vengeance LPX 3000MHz DDR4-3000 Memory
SSD/HDD: Samsung 860 Evo MZ-76E1T0B/EU 1 TB
GPU: XFX Radeon R9 270
PSU: XFX Pro XPS-750W-3XB XXX Edition Semi Modular Power Supply Unit
Chassis: Nanoxia Deep Silence 5 Rev. B Case - Anthracite Full Tower Case
 
Aug 8, 2021
4
0
10
0
I've tried another video card that didn't help unfortunately. I have put 1 stick of RAM in the correct slot. Absolutely nothing on the screen.
 

ASK THE COMMUNITY

TRENDING THREADS