Question PC Crashing / BSODs / Games randomly closing to desktop

Feb 3, 2019
17
0
10
0
My PC has been crashing and gives me one BSOD almost every single day. This has been happening ever since I built it which was in January 2018. They've increased now.

The crashes mainly occur when I'm gaming but also occur when I am going minimal stuff like having one chrome tab and spotify open.

Sometimes games randomly close themselves to the desktop or give me errors like "the application has crashed and will now close" (fortnite) or "a critical error has occurred and the process must be terminated" (league of legends). When league crashes, I cannot access anything like task manager or any other programs but i can hear the game music and other sound too and have to hard reset my computer.

I've ran memtest86 (4 passes) on my two sticks of ram both together and independently and they have shown no errors. I have also tried resetting my PC and starting with a fresh install of Windows 10. I have also updated my BIOS to the most recent one and I have not overclocked anything.

PC Specs:
CPU: Ryzen 3 2200G
GPU: GTX 1050ti 4GB
MOBO: Gigabyte AB350N Gaming
RAM: 8gb DDR4 Corsair Vengeance LPX
PSU: Corsair CS550

BSODs include SYSTEM_THREAD_EXCEPTION, PROCESS_HAS_LOCKED_PAGES, DPC_WATCHDOG_VIOLATION and many others.

Any help or potential solutions would be greatly appreciated as I have no idea what to try next and no idea of what could be causing these crashes.

 
Last edited:
Feb 3, 2019
17
0
10
0
System thread exception not handled is blaming DirectX. Most DirectX errors are caused by GPU drivers.

Try this - https://forums.tomshardware.com/faq/how-to-perform-a-clean-install-of-your-video-card-drivers.2402269/

Process has locked pages is unusual, can't say I seen it before. See if replacing Nvidia drivers fixes problems.

I will ask someone to convert dump files for me so I can read them :)
Hi, thank you so much for the reply.
I’ve already done a fresh install of my gpu drivers. I done that once ages ago and once yesterday after I got the BSOD.
 

gardenman

Admirable
Herald
Hi, I ran the dump files through the debugger and got the following information: https://pste.eu/p/Sgxf.html
File information:072019-6062-01.dmp (Jul 19 2019 - 08:40:17)
Bugcheck:KERNEL_SECURITY_CHECK_FAILURE (139)
Probably caused by:partmgr.sys (Process: System)
Uptime:0 Day(s), 5 Hour(s), 09 Min(s), and 14 Sec(s)

File information:071819-6046-01.dmp (Jul 18 2019 - 00:35:47)
Bugcheck:PROCESS_HAS_LOCKED_PAGES (76)
Probably caused by:ntkrnlmp.exe (Process: League of Lege)
Uptime:0 Day(s), 15 Hour(s), 25 Min(s), and 23 Sec(s)

File information:071819-5968-01.dmp (Jul 17 2019 - 08:32:44)
Bugcheck:SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007E)
Probably caused by:memory_corruption (Process: LeagueClientUx)
Uptime:0 Day(s), 11 Hour(s), 50 Min(s), and 31 Sec(s)
Comment: The overclocking driver "RTCore64.sys" was found on your system. (MSI Afterburner)

BIOS information was not included in the 1st dump file. This can sometimes mean an outdated BIOS is being used.

This information can be used by others to help you. I can't help you with this. Someone else will post with more information. Please wait for additional answers. Good luck.
 
Feb 3, 2019
17
0
10
0
Hi, I ran the dump files through the debugger and got the following information: https://pste.eu/p/Sgxf.html
File information:072019-6062-01.dmp (Jul 19 2019 - 08:40:17)
Bugcheck:KERNEL_SECURITY_CHECK_FAILURE (139)
Probably caused by:partmgr.sys (Process: System)
Uptime:0 Day(s), 5 Hour(s), 09 Min(s), and 14 Sec(s)

File information:071819-6046-01.dmp (Jul 18 2019 - 00:35:47)
Bugcheck:PROCESS_HAS_LOCKED_PAGES (76)
Probably caused by:ntkrnlmp.exe (Process: League of Lege)
Uptime:0 Day(s), 15 Hour(s), 25 Min(s), and 23 Sec(s)

File information:071819-5968-01.dmp (Jul 17 2019 - 08:32:44)
Bugcheck:SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007E)
Probably caused by:memory_corruption (Process: LeagueClientUx)
Uptime:0 Day(s), 11 Hour(s), 50 Min(s), and 31 Sec(s)
Comment: The overclocking driver "RTCore64.sys" was found on your system. (MSI Afterburner)

BIOS information was not included in the 1st dump file. This can sometimes mean an outdated BIOS is being used.

This information can be used by others to help you. I can't help you with this. Someone else will post with more information. Please wait for additional answers. Good luck.
I have MSI Afterburner installed however I have not overclocked or underclocked anything. Everything is set at default.

As for my BIOS, it is up to date and I know this as I flashed it two weeks ago. :/

Should I use memtest86+ instead of memtest86 to test my ram again?
 

Colif

Titan
Moderator
first BSOD mentions partmgr.sys which is the partition manager and part of windows... not something I regularly see crashing, so perhaps it was caused by 1str program I suggest you uninstall
I would remove this

Jun 15 2009 pwdrvio.sys MiniTool Partition Wizard https://www.partitionwizard.com/

as its too old.

Your lan drivers are old as well, yours are from 2015, newest on Gigabyte site are from Feb 2019
either download them from the LAN section here - link - or download Gigabyte App Centre and use it to check all your drivers are up to date - Utilities

I assume you use Wifi given they more up to date

DirectX can also be audio
your realtek Audio drivers are from 2017, newest on Gigabyte site are 2019. App centre should offer updates.

are you using a Blue Snowball microphone? I only ask as I see C-Media USB Audio Class 1.0 and 2.0 DAC Device Driver
 
Feb 3, 2019
17
0
10
0
first BSOD mentions partmgr.sys which is the partition manager and part of windows... not something I regularly see crashing, so perhaps it was caused by 1str program I suggest you uninstall
I would remove this

Jun 15 2009pwdrvio.sysMiniTool Partition Wizard https://www.partitionwizard.com/

as its too old.

Your lan drivers are old as well, yours are from 2015, newest on Gigabyte site are from Feb 2019
either download them from the LAN section here - link - or download Gigabyte App Centre and use it to check all your drivers are up to date - Utilities

I assume you use Wifi given they more up to date

DirectX can also be audio
your realtek Audio drivers are from 2017, newest on Gigabyte site are 2019. App centre should offer updates.

are you using a Blue Snowball microphone? I only ask as I see C-Media USB Audio Class 1.0 and 2.0 DAC Device Driver
I did previously have minitool partition wizard installed but not anymore. I just removed pwdrvio.sys.

Downloaded the Gigabyte App Centre to update my drivers. I dont use wifi I have an ethernet cable hooked up to my pc.

I'm not using a Blue Snowball microphone, I'm actually using this one https://www.amazon.com/BC-Master-Microphone-USB-Condenser/dp/B072HJ1683

Will try gaming and using my PC today to see how it goes.
 
Feb 3, 2019
17
0
10
0
I did previously have minitool partition wizard installed but not anymore. I just removed pwdrvio.sys.

Downloaded the Gigabyte App Centre to update my drivers. I dont use wifi I have an ethernet cable hooked up to my pc.

I'm not using a Blue Snowball microphone, I'm actually using this one https://www.amazon.com/BC-Master-Microphone-USB-Condenser/dp/B072HJ1683

Will try gaming and using my PC today to see how it goes.
Last night I swapped around my ram sticks so they are in different slots than they originally were. I also let the Windows Memory Diagnostics Tool run overnight to test both sticks of ram and when I logged onto my PC an error dialogue showed up so maybe both or one of my sticks are bad? This is confusing though because I just used Memtest86 the other day and it showed up with no errors when the ram sticks were in the original slots, the test would go back to the main screen after finishing all passes and not display whether the test detected errors or was a success so I assumed it was a success

Check screenshots below:
- View: https://imgur.com/a/301HvMY
 
Last edited:
Feb 3, 2019
17
0
10
0
Last night I swapped around my ram sticks so they are in different slots than they originally were. I also let the Windows Memory Diagnostics Tool run overnight to test both sticks of ram and when I logged onto my PC an error dialogue showed up so maybe both or one of my sticks are bad? This is confusing though because I just used Memtest86 the other day and it showed up with no errors when the ram sticks were in the original slots, the test would go back to the main screen after finishing all passes and not display whether the test detected errors or was a success so I assumed it was a success

Check screenshots below:
- View: https://imgur.com/a/301HvMY
Just ran Memtest86 with the ram in the different slots than they originally were in (I only have 2 slots on this mobo) and I got 7 errors on the first and second pass in test 1. Super confused right now... I don't know why its showing errors when I swap the ram around but not showing errors when they were in their original slots.
 
Feb 3, 2019
17
0
10
0
Just ran Memtest86 with the ram in the different slots than they originally were in (I only have 2 slots on this mobo) and I got 7 errors on the first and second pass in test 1. Super confused right now... I don't know why its showing errors when I swap the ram around but not showing errors when they were in their original slots.

XMP was enabled.
Just swapped them back around and disabled xmp. Memtest showing no errors now.
 

Colif

Titan
Moderator
Are the ram sticks on the motherboards QVL list? normally Gardenmans report would show details such as ram codes but yours isn't showing us anything. so I can't tell. It could be a clue something wrong with motherboard.

Max error count for memtest is 0, so if that stick that reported 7 errors doesn't report any in the other slot, it could be a sign its the motherboard itself.
Memory problems will affect everything and cause BSOD and blame random things that aren't the cause
 
Feb 3, 2019
17
0
10
0
Are the ram sticks on the motherboards QVL list? normally Gardenmans report would show details such as ram codes but yours isn't showing us anything. so I can't tell. It could be a clue something wrong with motherboard.

Max error count for memtest is 0, so if that stick that reported 7 errors doesn't report any in the other slot, it could be a sign its the motherboard itself.
Memory problems will affect everything and cause BSOD and blame random things that aren't the cause
The Ram sticks code is Corsair CMK8GX4M2A2400C14.

It’s weird because CPU-Z also shows absolutely no information about my ram apart from the fact that there is 8GB installed.

I checked the QVL list and the exact code is not listed there. Theres a very similar one with code CMK8GX4M2D2400C14.

The difference is the letters so I’m not sure if that means anything.
 

Colif

Titan
Moderator
I can find the ram model you have on the corsair website - https://www.corsair.com/us/en/Categories/Products/Memory/vengeance-lpx-black/p/CMK8GX4M2A2400C14#tab-overview - but I can't find the ram code your QVL is showing apart from 1 pcpartpickler link that doesn't show enough tech specs.

newegg link shows they both have same stats
Tested Latency 14-16-16-31
Tested Voltage 1.2V

I don't know what exact difference between A & D is myself.

I starting to think problem is motherboard. Not showing CPU-Z, dumps not showing any system stats, getting 7 errors on a working stick. I would think about getting PC looked at by experts, they will have parts they know work that they can swap in to test rest of PC
 
Feb 3, 2019
17
0
10
0
I can find the ram model you have on the corsair website - https://www.corsair.com/us/en/Categories/Products/Memory/vengeance-lpx-black/p/CMK8GX4M2A2400C14#tab-overview - but I can't find the ram code your QVL is showing apart from 1 pcpartpickler link that doesn't show enough tech specs.

newegg link shows they both have same stats
Tested Latency 14-16-16-31
Tested Voltage 1.2V

I don't know what exact difference between A & D is myself.

I starting to think problem is motherboard. Not showing CPU-Z, dumps not showing any system stats, getting 7 errors on a working stick. I would think about getting PC looked at by experts, they will have parts they know work that they can swap in to test rest of PC
Okay, I will definitely try to get that done as soon as possible. I’ll leave an update to let you know the outcome once I do
 
Feb 3, 2019
17
0
10
0
Okay, I will definitely try to get that done as soon as possible. I’ll leave an update to let you know the outcome once I do
Prime95 tester 1 and also tester 3 couldn’t complete one test and gave me an error saying

[Jul 25 19:17] Worker starting
[Jul 25 19:17] Beginning a continuous self-test on your computer.
[Jul 25 19:17] Please read stress.txt. Choose Test/Stop to end this test.
[Jul 25 19:17] Test 1, 88000 Lucas-Lehmer iterations of M3835553 using FMA3 FFT length 192K, Pass1=768, Pass2=256, clm=2.
[Jul 25 19:18] FATAL ERROR: Rounding was 0.4999318487, expected less than 0.4
**[Jul 25 19:18] Hardware failure detected, consult stress.txt file.
[Jul 25 19:18] Torture Test completed 0 tests in 0 minutes - 1 errors, 0 warnings.

[Jul 25 19:18] Worker stopped.**
 
Feb 3, 2019
17
0
10
0
Update
I tested my friends spare ddr4 ram in my pc and no crashes or BSODs occurred. I have now ordered new ram and will update to let you know if it starts crashing again.
 

ASK THE COMMUNITY