Question PC does not boot ?

Aug 8, 2022
2
0
10
0
Hi Tom's hardware,

My desktop pc does not boot.
The issue began when I decided to fix two USB ports on the top of the case that seemed to be dead.
When I tried to remove the GPU (GeForce RTX™ 3080 SUPRIM X 10G), I noticed that it was stuck on the motherboard lock (ASUS PRIME B450M-A II).
I applied a bit of pressure on the lock, and I was able to remove the GPU.
After removing the GPU, I noticed that the USB pins were hidden below the motherboard, and not connected.
Therefore, I connected the USB pins and reseated the GPU and noticed that the USB ports were alive, they could give energy to any device.
Nevertheless, as a side effect when I tried to start the PC, led and fans were turning on as regular, including the GPU ones, however I got no video signal and mouse and keyboard did not light up.

Troubleshooting
  • I tried to switch the motherboard with an identical one (ASUS PRIME B450M-A II) it did not solve the issue.
  • I connected an old GPU sapphire, same issue. Furthermore, for the GPU sapphire LEDs turned on, but fans did not.
  • I tried to remove, substitute and reseat the CMOS battery, same issue.
  • I noticed that on the GPU SIM (GeForce RTX™ 3080 SUPRIM X 10G) two units are shorter, one top and one bottom, and I do not know if this is normal or if they got damaged during any reseating process.
  • I tried to boot the PC without any GPU, but connecting the monitor via HDMI directly on the motherboard, same issue.
Any idea on what could be the cause of the issue? Is there anything else I could try?

Thanks in advance
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

I applied a bit of pressure on the lock, and I was able to remove the GPU.

The lock that you mention, the paddle/fin shaped latch, needs to be pushed down(from the angle at which the image is posted above) and that disengages the GPU's rear end of the slot.

I tried to boot the PC without any GPU, but connecting the monitor via HDMI directly on the motherboard, same issue.
If you don't have an APU on the board, then you won't get display out from the motherboard's display ports.
 
Aug 8, 2022
2
0
10
0
Thank you for your reply

I know that in order to have video ouput I need an apu, but why keyboard and mouse do not light up ?
All the other devices tha I connet to the USB ports light up, mouse and keyboard do not , regardeless of which USB port I use to plug them in.

Also I tried to insert another GPU an old sapphire, but still no video, no mouse no keyboard.

Mouse and keyboard do not light up, even without any gpu.
 

ASK THE COMMUNITY