[SOLVED] PC does not detect the two audio devices that are connected.

DarkstyleR

Distinguished
Apr 8, 2013
40
0
18,530
0
I have a HP elitedesk 800 g1 sff that I have connected speakers to in the Line-out connector for powered audio devices (green - number 11) .

When I try to insert headphones in the front headphone connector (number 5) the audio from the speakers stops and it transfers to the headphones(speaker audio stops) .

The sound menu only shows one audio device connected named "Speakers":

Here's what I've tried so far:
-Updated drivers to:
Realtek High Definition Audio Driver6.0.1.8328 Rev.A
- Went to DTS Audio Control and enabled "playback multi-streaming".
This does show two audio devices in the sound menu but
but "speakers" is now the internal audio speaker built in the PC (which I do not want to use) and "realtek hd audio 2nd output" is the headphones (or if I disconnect the headphones then it is the normal speakers).

Any ideas how I can get both the speakers and headphones to appear so I can switch between them?
 

getochkn

Polypheme
Moderator
It's a feature. Plug in speakers in back, play music need to game, drop a headset in the front port and the rear disables. It was always a pain having to unplug things to get the right device I wanted sound 9ut of.


How to "fix" this, I have no idea.
 
Reactions: white.a.drew
I have a HP elitedesk 800 g1 sff that I have connected speakers to in the Line-out connector for powered audio devices (green - number 11) .

When I try to insert headphones in the front headphone connector (number 5) the audio from the speakers stops and it transfers to the headphones(speaker audio stops) .

The sound menu only shows one audio device connected named "Speakers":

Here's what I've tried so far:
-Updated drivers to:
Realtek High Definition Audio Driver6.0.1.8328 Rev.A
- Went to DTS Audio Control and enabled "playback multi-streaming".
This does show two audio devices in the sound menu but
but "speakers" is now the internal audio speaker built in the PC (which I do not want to use) and "realtek hd audio 2nd output" is the headphones (or if I disconnect the headphones then it is the normal speakers).

Any ideas how I can get both the speakers and headphones to appear so I can switch between them?
I have been dealing with this issue since i built my previous pc and gave up on it it made me so mad it got put in the closet and left.... Which makes no since because the next build i did was the EXACT SAME and dosnt have this issue.
Any componets the same?
Asus rog strix b450 f gaming
Ryzen 5 3600x
3600mhz geil evo ram
Deepcool matrix50
Evga plat 750w psu
Rtx 2080ti
 
I have been dealing with this issue since i built my previous pc and gave up on it it made me so mad it got put in the closet and left.... Which makes no since because the next build i did was the EXACT SAME and dosnt have this issue.
Any componets the same?
Asus rog strix b450 f gaming
Ryzen 5 3600x
3600mhz geil evo ram
Deepcool matrix50
Evga plat 750w psu
Rtx 2080ti
I get it is hp so mobo is deffently not but
 

getochkn

Polypheme
Moderator
It's a feature. Plug in speakers in back, play music need to game, drop a headset in the front port and the rear disables. It was always a pain having to unplug things to get the right device I wanted sound 9ut of.


How to "fix" this, I have no idea.
 
Reactions: white.a.drew

ASK THE COMMUNITY