Question PC freezes whenever bumped and "no signal" to monitor ?

Sep 24, 2021
6
0
10
0
So my pc has been having this problem for months, where it’ll freezes and the audio goes brrr whenever the pc case is bumped, even just a small bump/kick.

Afew days ago I accidentally kicked the side of the pc case that causes it to freeze. I had to do a force shut down and when i turn it back up it went to a blue screen, i restarted it and it went to the desktop for like 15 secs before it frozen again, and now it’s just on a no signal detected on my monitor.

Reseated gpu and rams, All fans are on, i tried connecting monitor to both gpu and mobo, tried different monitor, tried to put ram into different slots, none of them works. Also my mobo has 4 slots of ram which the 2 on the right are defected, if i put any ram into the right slot then the mobo will beep, so my 2 rams have been put on the left slots for years.

A friend of mine said he’s not sure what’s the problem is, he guesses that it might be either the mobo or the rams. He said it’s unlikely the mobo cause it could still beep when i put rams on right slots (so it’s working he said). I need an help figuring out the problem so i can replace the parts, ty.

Spec:
I7 7700k
Gtx 1050
Ram ripjaws v ddr4 2x4gb
Mobo asus prime h270m-plus
Samsung ssd and wd hdd
Psu gamemax atx gp-550w
 
So my pc has been having this problem for months, where it’ll freezes and the audio goes brrr whenever the pc case is bumped, even just a small bump/kick.

Afew days ago I accidentally kicked the side of the pc case that causes it to freeze. I had to do a force shut down and when i turn it back up it went to a blue screen, i restarted it and it went to the desktop for like 15 secs before it frozen again, and now it’s just on a no signal detected on my monitor.

Reseated gpu and rams, All fans are on, i tried connecting monitor to both gpu and mobo, tried different monitor, tried to put ram into different slots, none of them works. Also my mobo has 4 slots of ram which the 2 on the right are defected, if i put any ram into the right slot then the mobo will beep, so my 2 rams have been put on the left slots for years.

A friend of mine said he’s not sure what’s the problem is, he guesses that it might be either the mobo or the rams. He said it’s unlikely the mobo cause it could still beep when i put rams on right slots (so it’s working he said). I need an help figuring out the problem so i can replace the parts, ty.

Spec:
I7 7700k
Gtx 1050
Ram ripjaws v ddr4 2x4gb
Mobo asus prime h270m-plus
Samsung ssd and wd hdd
Psu gamemax atx gp-550w
Must be something loose.
 

ASK THE COMMUNITY