Question PC keeps turning off

Feb 19, 2020
12
1
15
0
Please help
I’ve just built my first pc with the following:

Corsair 465x case
H100i AIO Cooler (with 2 Rgb LL120 fans)
4 more LL120 fans
i5 9600k CPU
2060 Super GPU
Corsair RM750X PSU

Initially things were ok although pc turned off once or twice. PC now turns off every time after approx 5 mins and will not turn back on.
mid I leave for an hour it will, but then 5 mins later the same thing happens. pC doesn’t appear hot and fans seem fine.
re cooler, what rpm or temp should it be?
Pls help as I think it’s the PSU but really don’t know. Thanks
 

Schlachtwolf

Upstanding
Jun 22, 2019
274
60
290
22
With that cooler it should run at anywhere from 30-40c idle depending on room temp. Core temp is ok for measurement. Did you remember to apply Thermal paste to the CPU?

Are any lights on the Motherboard lighting up in the colours Red or Yellow? What make of Mobo is in the build and what RAM, its speed and how much is installed?
 
Reactions: kyriac05
Feb 19, 2020
12
1
15
0
Thanks for the reply.
So you’re saying I should check CPU temp to confirm cooler is working. Cooler comes with thermal paste so no, I didn’t add. What temp should CPU be? It’s showing as 20 degrees.
MOBO is ASUS Prime z390-a and is showing as 21 degrees
RAM are 2 x 8GB Corsair Vengeance RGB showing as 22 degrees

Having just turned it on in order to get temps for you, it turned itself ooff again and then back on briefly that allowed me to look In iCue where fans are showing as around 650 rpm.
 
Feb 19, 2020
12
1
15
0
All this was done with back of case off but wires and PSU still inside case.
Ive actually ordered another PSU today as this one is brand new and can return if faulty.
Hoping this will resolve.
is that likely given the above?
 

Schlachtwolf

Upstanding
Jun 22, 2019
274
60
290
22
Ok it would appear the cooler is running fine and the CPU is not shutting down through thermal issues. Sounds like your PSU has an problem and even a new one can be a Monday morning one.

Just make sure that all connections are secure before you star the PC with a new PSU, GPU RAm seating, SATA connections etc after you hookup the new PSU and things may work loose during the removal of the old and installation of the new PSU.

Best of luck !!
 
Reactions: kyriac05
Feb 19, 2020
12
1
15
0
Many thanks.
Also, it won’t switch back on if I try and will only do so a significant period afterwards. Last point but due to amount of RgB I have, there’s the Corsair Lighting Node Core that comes with my 465x case as well as a Commander Pro. One of the items showing in
there had the voltage (is it?) where two were showing as 5ish but one was 12ish. Cant exactly remember what it is and can’t log in either!
 
Too many addons and bling to precisely pinpoint the issue.

Reduce the PC to the bare minimum: motherboard, RAM, CPU, PSU, stock air cooler, and use integrated graphics only. Assemble everything outside of the case for testing purposes. Test as much as you can. If it works, add components one by one. Work from there.
 
Feb 19, 2020
12
1
15
0
Thanks all. I’ve tried outside of case and it turns off and then on again on its own. Question re PSU: should PSU fan constantly rotate as it doesn’t and seems to be a bit erratic? If it should, then this is the error.
 
Feb 19, 2020
12
1
15
0
Thanks all. I’ve tried outside of case and it turns off and then on again on its own. Question re PSU: should PSU fan constantly rotate as it doesn’t and seems to be a bit erratic? If it should, then this is the error.
And finally, when it does turn back on after a second or two, the PSU fan comes on briefly and then turns off.
 
Feb 17, 2020
18
1
15
0
Thanks all. I’ve tried outside of case and it turns off and then on again on its own. Question re PSU: should PSU fan constantly rotate as it doesn’t and seems to be a bit erratic? If it should, then this is the error.
yes psu fan should rotate constantly...so i think is ur PSU problem
 
Reactions: kyriac05
Feb 19, 2020
12
1
15
0
That’s it then, I hope. It was the only blooming item I didn’t buy brand new too. Got it as new on eBay from a genuine shop though. They’ve already agreed to refund and my new one turns up in an hour. I’ll be in touch to confirm and once again, thanks to all 👍🏼
 
Feb 19, 2020
12
1
15
0
It was. New one works fine. Also, I downloaded RGB Fusion 2 for my Gigabyte 2060 Super and both times I opened it, my pc froze. Reading online, it appears that it’s caused a lot of people’s pcs to crash since new update so anyone reading this, bear it in mind. Thanks again to all
 
Reactions: Schlachtwolf

Schlachtwolf

Upstanding
Jun 22, 2019
274
60
290
22
iQue, Aura, Mystic light, RGB Fusion are nightmares, I have iQue for my RAM and an Aura Mobo.... getting them to work together was a mission !!!! But we got there....

Tip just look for an older version of Fusion, it should light your rig fine. You may need to try a few versions until you find the one that works for you. If you uninstall a version be SURE to run CCleaner or similar to clean the Registry as files get left behind that will cause a conflict and mess up newly installed versions.
 

ASK THE COMMUNITY

TRENDING THREADS