Question PC no longer powers on.

Dec 16, 2019
3
0
10
0
I'll try to make this brief; any advice is appreciated, thanks in advance.

PC stopped powering on like normal when I press the power button on the front of the case.

PSU switch is/was flipped to | and not O, however I tried O as well, just in case. Swapped power cords with several known working, same luck, used old power cord on other devices and it works just fine. Surge protector is switched on, and have three other small devices plugged into it, all functioning properly.

I have tried everything relevant in the Perform These Steps Before Posting sticky. PSU seems to be alright, at least not under load. I disconnected it from everything except the 7 fans in the case and bridged the power pin and a ground, PSU started up just fine, all fans/accessories working. During this time, I probed each pin in the 24-pin MB connector with a multimeter, and each had the correct voltage for my MB pin out specifications.

At this point, I think the problem is narrowed down to either the MB, CPU, or possibly the PSU is not functioning while under load.

Currently only have the PSU, MB, CPU, and RAM still connected in the case, but I think my next step will be pulling everything out of the case and breadboarding one piece at a time, although I'm not sure it will give much more insight on what the problem is.

While breadboarding, I think I will swap back to my old processor (functioning upon swapping to new one) to see if that makes a difference.

Possibly relevant info:

The night before first experiencing no power on, I plugged a new USB Bluetooth dongle into one of the front top case USB ports, it did not show up in windows, and immediately (and possibly coincidentally?) my USB wifi adapter and USB keyboard that were plugged into 2 of the front case ports stopped working. I moved all 3 USB peripherals to ports directly on the MB in the back, all worked fine after that point. May not be relevant, I'm unsure.

Also, the night before (same day as the USB problems above), when shutting down the PC for the night before bed, it would shut down for a few seconds, all power off, fans/leds/everything, but after several seconds would start back up by itself, no input from me. After trying to shut it down from windows 2-3 more times, with it starting back up by itself each time, I eventually switched the PSU switch off, from | to O during bootup. It was not doing any Window's Updates as far as I'm aware, no notifications in windows previously, and nothing during these self-starts saying windows was updating.

Motherboard: Gigabyte GA-Z68X-UD3H-B3, 8 years old.
CPU: i7 3770k @ 4.2ghz, passed 24hr stability tests, stable since I bought via Ebay 2 months ago. Used OC guides from Tom's, including stability/thermal tests.
RAM: 32gb DDR3 @ 1866mhz XMP. All 4 sticks passed 2 full passes of memory testing. Stable for 2 months, bought 2 months ago.
Graphics: RTX 2060, factory OC, has been stable/perfect since bought 2 months ago. No manual OC from me.
PSU: Corsair TX850 Bronze, 8 years old, only issue (until possibly now) is the fan has started to make a tiny more noise recently, planned on replacing fan.
Storage: OS - 300gb from 5x SSDs in RAID0, SSDs are all 8 years old, but no problems and recently said 92% life left in CrystalDisk.
Storage: NVMe 1tb SSD via adapter, 2 months old, haven't had problems.
Expansion: NVMe to PCIe adapter for above storage. 2 months old.
Case: Thermaltake Level 10 GT, 8 years old.
Fans: 5 case fans, 2 CPU fans, all fans replaced ~6 months ago, all working.
CPU Heatsink: Hyper 212 EVO, push pull. 8 years old. Used on my i7 2600k until 2 months ago, swapped to current CPU.

Any advice/thoughts/comments would be appreciated, thanks.
 
Dec 16, 2019
3
0
10
0
I forgot to mention that I tried jumping the motherboard power pins, just in case the power button on my case is the culprit, but it didn't work either. Tried the reset switch pins as well, nothing.

And just finished hard resetting the CMOS, no change. Tested battery, still giving 3 volts.
 

ASK THE COMMUNITY

TRENDING THREADS