Pc not starting up

Bitvargen

Honorable
Feb 1, 2014
3
0
10,510
0
I built a completely new computer from scratch about a month ago. It have been working fine since. Only problem I've ever had was once it shut down randomly without a reason. However now that exact thing happed again. I had been using it for a few hour and it randomly shut down, seemingly without a reason. First thing I did was to try and start it up again. No response. I tried leaving it overnight before starting it, still nothing.
I'm completely stuck now and have no idea what the problem is.

When my pc shut down and I tried to restart it but it didn't work I did open the pc but nothing seemed to me to be especially varm.
I do know my psu is working to some extent since my keboard and mouse have lighting on when I plug in power. My gpu also iave a very little lamp gloving when power is connected.
When I say I got no response from trying to start my pc I mean not a single fan are moving, not a single land or light are turning on/off. Absolutely no response in any way to my knowledge.
 

Bitvargen

Honorable
Feb 1, 2014
3
0
10,510
0
Thanks for talking the tume to answer me.
I looked through the post and as they mainly are used to get a system up and running for the first time (and with my limited knowledge) I feel like most of them I can check off. However I did try switchING around my ram modules, but no further result. I sadly haven't got one if the speakers do I might see if I can find one.
 

Bitvargen

Honorable
Feb 1, 2014
3
0
10,510
0
Of course.

Intel core i5 7600K 3.8GHz

Samsung 850 EVO series 500GB

Gigabyte GA-Z170-Gaming K3

Corsair Vengeance 3x8GB

Corsair 650W

Cooler Master Hyper 212 Evo

Asus GeForce GTX 1060 6GB

Here's my specs, I do have the full namn of everything but it would take some time to find.
 

ASK THE COMMUNITY

TRENDING THREADS