Question Pc not turning on after installing liquid cooling.

Nov 25, 2020
3
0
10
0
Hello everyone,
New to the pc building and having help from my brother on the build. I have a X570 with the Ryzen 7 cpu. I recently bought liquid cooling from Amazon from a company called Id cooling. After install my computer would not turn back on. We figured it was a power issue went out and bought new power. Installed and same problem occurred, he then suggested it was the mother board. I just picked up a new board today and yet again the same issue. Would the cpu cause the issue that I’m having or could there be something else?
 
Im not familiar wit that brand of AIO but it sounds like you don't have the radiator fans or the AIO pump plugged into the correct headers on the motherboard. What motherboard do you have exactly?

You need to make sure you plug the radiators fans into the CPU_FAN header and the pump into either a OPT_CPU or if your motherboard has it a AIO_PUMP (it could be labeled differently) header. If you motherboard doesn't have either of those last two headers go ahead and use the CPU_FAN header for the pump and put the radiator fans on a CHA_FAN header. I only say this because if the pump fails if it's plugged into the CPU_FAN header it adds a level of safety since the computer wont boot then.

View: https://www.youtube.com/watch?v=zGi-hTkRy00
 
Nov 25, 2020
3
0
10
0
Im not familiar wit that brand of AIO but it sounds like you don't have the radiator fans or the AIO pump plugged into the correct headers on the motherboard. What motherboard do you have exactly?

You need to make sure you plug the radiators fans into the CPU_FAN header and the pump into either a OPT_CPU or if your motherboard has it a AIO_PUMP (it could be labeled differently) header. If you motherboard doesn't have either of those last two headers go ahead and use the CPU_FAN header for the pump and put the radiator fans on a CHA_FAN header. I only say this because if the pump fails if it's plugged into the CPU_FAN header it adds a level of safety since the computer wont boot then.

View: https://www.youtube.com/watch?v=zGi-hTkRy00
Hey thanks for replying we actually found out that the cpu has failed. Thank you for your help.
 

ASK THE COMMUNITY

TRENDING THREADS