[SOLVED] PC suddenly not sending any signal to monitors ?

Jul 22, 2022
2
1
10
0
For backstory: I was having a problem where every time I bumped my desk to hard my entire pc would shutdown and restart. It did it again today so when it booted back up I shut it back down, unplugged the power cord and drained the motherboard, and went in the case and gently pushed on all the power slots on the motherboard. I turn my pc back on, and suddenly neither of my monitors are receiving input.

They don't even register that they're connected to something. So far I know: it's not the monitor or cables, I've tried 3 different monitors with hdmi, displayport, and usb-c. I unplugged my gpu and plugged the monitor straight into the motherboard, still no signal at all. I've removed the battery from the motherboard and tried a complete power drain. At this point all I can think of is the motherboard somehow got damaged by me making sure the power cables were in correctly.
 

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and OS information.

Include PSU: make, model, wattage, age, condition (original to build, newer, refurbished, used)?

Disk drive(s): make, model, capacity, how full?

You mentioned that you "gently pushed on all the power slots". Understood to some extent but you must also check that all connectors, cards, RAM, and jumpers are fully and firmly in place.

Also refer to the motherboard's User Guide/Manual to ensure that you properly clear CMOS.

And remember to check all power connections and devices (power strips, surge protectors, etc. from wall outlet to the computer.

Something could be loose there. Even inside the wall outlet.

Especially if bumping the desk causes power to be lost.
 
Jul 22, 2022
2
1
10
0
Remove the hdds ssds and try powering on

Use a minimum configuration if it still doesn't work
Psu, motherboard, monitor, CPU, keyboard, one ram
Remove the hdds ssds and try powering on

Use a minimum configuration if it still doesn't work
Psu, motherboard, monitor, CPU, keyboard, one ram
Doing this worked, I slowly plugged everything else in one by one,restarting my pc every time, everything suddenly works now. No idea why
 
Reactions: helpstar

ASK THE COMMUNITY

TRENDING THREADS