[SOLVED] PC Turns on but no display, no power to usb ports, and the power button has no light coming from it.

Feb 19, 2019
51
0
40
2
^ as title says My pc when i press the power button everything is fine my fans spin my pc sounds like it is booting up, but the power button has no light and i cant hold it down to turn off the pc i have to manually unplug it from behind, i have no usb ports that are working and if i were to plug an hdmi cable into my gpu to the monitor i would get no display. I have had this issue ongoing for about a week now much help is appreciated
 

Grobe

Distinguished
Jan 22, 2009
552
7
19,165
88
What specifications? Have you built it yourself? How old is the computer? WHen did this problem start, and is there an event you know that may have caused this failure?
 
Feb 19, 2019
51
0
40
2
What specifications? Have you built it yourself? How old is the computer? WHen did this problem start, and is there an event you know that may have caused this failure?
GPU: GTX 1050
CPU: AMD ATHLON II X4 645
RAM: 8GB
MOBO: Not sure exactly which motherboard but its a foxconn

I did not build this pc myself it was a gift from atleast 5 years ago.
The pc itself is about 5 or 6 years old but i doubt that is an issue.
The problem started just about a week ago, Im not sure how it happened exactly but i concluded that its not the cpu itself i put the cpu in another pc and it was fine and the socket isnt broken or anything either. The ram i have tried separately and with none in the pc and the same thing happens. Strange enough this same problem happened to me about a week ago but i seem to have fixed it by unplugged something and plugging it back it but that seems to not be the solution this time.
 
Feb 19, 2019
51
0
40
2
It depends if it can touch the mainboar or any part of it. If it have rested against motherboard, a short cicruit may occur, which leads to a defective mobo.
I found the reason it was a cpu issue i had 2 broken pins on my amd cpu and just got a new one yesterday. But in the process of taking the cpu out my lever on the socket broke off so im trying to fix it
 

Similar threads


ASK THE COMMUNITY