Question PC won’t boot after GPU install

Mar 15, 2019
5
0
10
0
Hello I installed a Sapphire RX 580 inside my pc yesterday I turned it on and it worked for a couple seconds until the windows login page than suddenly crashed it wasn’t turning on so I took it out and it still did not turn on I tried it later that day I just reinstalled the 24 pin EATX and the case wires and it worked than crashed I kept turning it on it kept crashing I put everything at stock there was one point where it was working upon installing the amd driver it crashed now anything I try won’t work reinstalling cables etc aren’t working when I try to power it on now it just gives me a clicking sound and I’m not sure where it’s coming from I think the power supply I’m not sure but the rgb on the motherboard stays lit up

Ryzen 5 2600x
Hyper 212 LED
Asus x470-pro
2x16 gb 3200 Corsair vengeance RgB
2 TB Seagate Barracuda 7200RPM
Sapphire RX 580 Nitro+
EVGA Supernova 650W G3 80+ gold
 
Mar 15, 2019
5
0
10
0
you are describing a hardware instability issue.
Is the GPU new ?
Does the system post ?
Can you try booting from another drive ?
The GPU is fairly new it’s been in another system but just for test what do you mean by post and I would have to buy another hard drive please help
 

Andrei N

Reputable
Feb 22, 2016
193
3
4,765
43
the BIOS post is the visual/audio queue that the system is starting up. It's usually accompanied by the monitor showing the BIOS access key, hence posting.
A PC can post without video output, therefore the visual queue is the keyboard lock lights turning on and off.
The audio queue is the beep that you hear just before the system posts.

Now what do you mean by crash ? How far does the system get before it crashes ?
Are you referring to the system not starting up at all as crashing ?
 
Mar 15, 2019
5
0
10
0
the BIOS post is the visual/audio queue that the system is starting up. It's usually accompanied by the monitor showing the BIOS access key, hence posting.
A PC can post without video output, therefore the visual queue is the keyboard lock lights turning on and off.
The audio queue is the beep that you hear just before the system posts.

Now what do you mean by crash ? How far does the system get before it crashes ?
Are you referring to the system not starting up at all as crashing ?
When it first started up everything worked perfectly windows loaded up I was on the internet etc than it turned off it turned backed on and kept turning off after like 3 seconds now it doesn’t turn on at all no fans spinning no keyboard lit just the rgb on the motherboard and it makes a clicking noise not a beep every time I press the power button
 
Mar 15, 2019
5
0
10
0
So I took the power supply out I reinstalled everything and it was running perfect I even finished installing amd driver and even ran userbenchmark I had to go so I shut it down and when I came home I turned it on than like 20 seconds later it shut down and is doing the same problem again I took out my cPU reapplies paste changed the cpu cooler and I gave it time and then I turned it on it worked than 10 seconds shut off than it turned back on by itself than back off back on than off completely now it’s not turning on at all
 

ASK THE COMMUNITY

TRENDING THREADS