[SOLVED] PC won't power with RX6800 after sudden shutdown.

Jan 2, 2021
2
0
10
0
Hello all,

So, this year i built a new computer, some specs for information:

Ryzen 5 3600x
Tomahawk X570
RX6800
Seasonic Prime 750w

Last componet was the Powercolor RX6800 in mid November.

Everything was running fine, but yesterday, after around 4hours of cyberpunk 2077, and while i was just browsing and getting ready to end it for the day, the computer had a sudden shutdown...

Tried to power on again, nothing.

My first thought, the PSU died... so i removed the PSU, and tested with the tester thing that came with the PSU, it powers ok.

Plug everthing again, tried to power, still nothing... started to removed components one by one, and after i removed the RX6800 from the pcie the computer powered on ok.

Tried the GPU in a different PCIE slot, without cable extensions, with different cables that came with PSU, and the computer does not power once the RX6800 is on the PCIE.

When i press the power button, all i can hear is a "click" noise, coming from the PSU, i think is some sort of anti-surge, or anti-shortcircuit going off.

I have a Geforce 710 that i used while waiting for the new GPU, decided to try that... and suprise, computer powers on fine, and perform normally...

Unfortunately i don't have another PSU to test with the RX6800 to confirm that it is in fact the card... but it's my main suspect.

On bios, and stress testing the PC the PSU 5v / 12v never shown a sudden drop on energy or anything like that, and that is as much i remember to test.

So my question... is there any other kind of test i can do to confirm that the RX6800 suffered an early death, or try to get it to work, or is it time to give up and RMA?... :|

Thank you all for reading this and any help in advance.

Have a good day and a good 2021.
 
Jan 2, 2021
2
0
10
0
Just to update/close, powercolor rx6800 reference GPU died... received refund and changed to a sapphire rx6800 nitro+, working good so far.
 

ASK THE COMMUNITY

TRENDING THREADS