• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question Performance issues with Unreal Engine 4 games - Low GPU usage + low FPS

verdynius

Reputable
Mar 19, 2015
39
0
4,530
0
The problem: i got poor performance, low fps, stuttering when i'm playing UE4 games (PUBG, Gears 5, Jedi: Fallen Order, Borderlands 3 as of now).
System specs: Ryzen 2600, MSI RTX2060, HyperX Predator 16GB 3200Mhz CL16 memory, MSI Tomahawk B450 Mobo, Samsung NVME SSD, some cheap SATA SSD, and i'm playing on an ASUS VG279Q 144Hz display running in g-sync compatible mode.

The frustrating thing is, that i have poor performance with my GPU and CPU being utilized at 40-60%. CPU is nowhere near its limit.
The worst case was Gears 5, i played that game with 30-50FPS and my GPU sitting on a mind-blowing 40% usage. No matter what setting i changed, the FPS was the same. Jedi: Fallen order is a bit better, but most of the time my GPU is being utilized around 60%, and my FPS sits around 60, dipping in the 50's. The graphical settings that i change seems to have no effect on the game's performance. In Borderlands 3 i'm dipping into the 40's with just any settings, game is barely playable. Its a mess.

Here's the list i have tried doing to fix this, for months now, before creating this post:
  • Tweaked all the nVidia control panel settings (Threaded Optimization ->On, Energy Profile->High Perf, and others)
  • Windows Graphics Settings -> Games are set to High Performance
  • DDU'd the display drivers at least 10 times, trying out older / newer variants
  • Tweaked RAM OC settings (ran them on factory defaults), now its on 3200Mhz XMP Profile 1
  • OC'd the GPU / CPU (both on factory settings since)
  • Plugged off 2nd display
  • Setting a framerate cap in rivatuner
  • Updated the Chipset driver (all MOBO drivers actually)
  • Windows 10 is always on the latest version
  • Tried closing everything that is running in the background (literally everything, just system processes were left)
  • Changed the polling rate on my mouse
The windows install i have is a pretty fresh and clean one, built this PC in June. Everything else runs just fine, i don't have any defective hardware. I have been playing tons of other games with zero issues. I'm currently playing Red Dead Redemption 2 on stable 60-90 FPS with my GPU being utilized 98%; and the settings i change in the game are affecting the performance.
Am i missing something? Am i doing something wrong? Can i do anything about this to get it resolved? If it were a 'smaller' engine, then no problems, i just avoid the games that's using the engine, but its one the most popular engines nowadays...
 

verdynius

Reputable
Mar 19, 2015
39
0
4,530
0
For anyone in the future intertested in the solution : Flashed the Bios to version 7C02v17 (the last one before the 3000 series support), reset all the settings, and voila. My Gears framerates are in the 3 digit region, Borderlands framerates doubled, and everything is juuuuust fine.
 

ASK THE COMMUNITY

TRENDING THREADS