Question Ping Spikes with WiFi connection and weird latency with wired connection ?

Mar 10, 2021
36
0
40
1
So heres the issue.
I used to feel a delay when I used to play with a wired connection no matter what I did I didn't have packet loss or anything it was just that I felt that my latency was jumping up and down so I played like this for 1 year and noticed that it was driving me crazy I upgraded my pc and it was still there until 2 days ago that I switched to wireless.. the connection magically felt better even tho my ping went up by like 2-3 because its wireless.

Now I need to know how to optimize wireless properly because I notice that my delay in game felt wayyyy better (wireless) than before (wired) like all my shots connect no more desync issues teleporting issues without it showing it anywhere, But now that I'm on wireless I notice that my ping is stable it's just that it spikes up and down every 3-4 seconds and comes back down but like big spikes like from constant 20 ping to 50-60 ping and im right next to the router and have the internet to myself only (1000mbps and get 500mbps up and down on my pc) so I pinged google and it shows it on there too.. every 5 requests or so it goes from 14-16ping to 40-45ping and even tho my game feels wayy more responsive than it did before I notice that the spikes makes my character jitter a littlebit every couple seconds or so if you guys know how to fix this or if its a ISP issue it would make my year honestly.

(edit: after a couple more tests every 20 req or so I get a 200ms spike and then back down to 14 when pinging google another thing is TTL I dont know what it stands for but it jumps from 57 to 106 every request)

(Edit 2: so I pinged my router and I get the spikes as well is just not that high I get 2-3ms and it spikes up to 30-35 every couple seconds)
 
Last edited:
Mar 10, 2021
36
0
40
1
Make and model of your wireless adapter? Make and model of your wireless router? You could check and see if your wireless router is pending any firmware updates.
On the motherboard (asus maximus xiii hero) website it says this:
High-Performance Networking: Onboard WiFi 6E (802.11ax), Intel ® 2.5 Gb Ethernet, and ASUS LANGuard

And the router is a at&t one BGW210

(also worth mentioning that I tried another router [XR1000] and the same issues kept happening when I had wired.
Also have a 1gb internet adapter cause I heard there are some issues sometimes with the 2.5gb ones)
 
So if you have issue on ethernet connection also I would first suspect the asus so called "gamer" network bloatware. Not sure what they currently call this but you want to uninstall anything that talks about QoS on games or favoring certain traffic. This software causes all kinds of strange issues.

Did you add in a extra 1gb nic card. The 2.5g ones do have lots of issues but they are mostly resovled with the newer drivers. Problem is microsoft is very "helpful?" and update will put in generic drivers sometimes that have issues. You want the drivers directly from intel or realtek...too lazy to read the specs on your motherboard.
 
Mar 10, 2021
36
0
40
1
So if you have issue on ethernet connection also I would first suspect the asus so called "gamer" network bloatware. Not sure what they currently call this but you want to uninstall anything that talks about QoS on games or favoring certain traffic. This software causes all kinds of strange issues.

Did you add in a extra 1gb nic card. The 2.5g ones do have lots of issues but they are mostly resovled with the newer drivers. Problem is microsoft is very "helpful?" and update will put in generic drivers sometimes that have issues. You want the drivers directly from intel or realtek...too lazy to read the specs on your motherboard.
Yes I did add it but I get the same issues with the 1gb card so Im using the 2.5gb one (the one that came w the motherboard) and manually installed the WiFi_22.60.0_Driver64_Win10.exe driver also made sure theres no bloatware from asus what Im going to do is download 21h1 (currently on 1709) and download the lastest wifi driver to see if this fixes the issue I'll update in a couple hours

Update: I still have the same issue when pinging google/router and when playing any game on 21H1

Update: Downloaded the lastest intel wifi drivers tried WLAN Optimizer and it still jitters every 4-5 seconds exactly
 
Last edited:

ASK THE COMMUNITY

Latest posts