PLEASE HELP - Game Freezes / Crashes randomly

fernanespejo

Reputable
Oct 17, 2014
3
0
4,520
1
Every time I play a game (Shadow of Mordor, FF14: ARR) it randomly freezes or completely crashes the game. The frequency of the freezes vary between 30 mins - 1 hour and it requires me to close the game and re-launch it, but NEVER CRASHES THE PC. For the most part, the games run at sleek 90+ FPS at maximum settings but when the freeze happens, the game video stops but the sound plays as normal. No FPS drops prior to the freeze, just freezes for a couple of seconds. Some occasions when it recovers the screen goes black and goes back to running the game normally. I've only had the rig for a couple of days and it's my first time building a PC so I'm not exactly sure where I've gone wrong. Please find my specs below and steps I took to resolving the issue, but not luck:

- Installed necessary drivers for components: CPU / GPU / MOBO.
- Reseated all components in the rig to make sure there were no iffiness that happened during the building process.
- Manually controlled my GPU fan and increased instead of setting it to Auto to make sure that it's not my GPU overheating.
- Underclocked my GPU to 90%
- Changed game settings to Medium instead of Ultra to see any differences.

Please find my specs attached below:

OS: Win 8.1 64bit
CPU: Intel i5 4670K
MOBO: MSI Z97 PC MATE
GPU: ASUS AMD R9 290 DirectCU II OC
MEMORY: ADATA USA XPG V1.0 OC Series 8GB DDR3 1866MHZ (2x 4GB)
PSU: Thermaltake Smart Standard 750W
HD: WD 1TB Hard Drive
 

plywrlw

Admirable
Jul 5, 2014
2,811
0
7,960
474
Take a look at some of these suggestions http://www.crashwiki.com/top-10-fixes-shadow-mordor-crashes-errors-wont-start-black-screen-config-nvidia-sli-dx11-support-hd-textures-slow-mouse/

In particular, disable to built-in graphics for your CPU in the BIOS.

This doesn't sound exactly like your problem but is worth a go if the above doesn't help

#3 Shadow of Mordor – How to Fix Crash to Desktop on Startup
If you are experiencing crash to desktop just after starting up the game, you can try a few things to fix it:

First, navigate to C:\Users\username\Documents\ and try deleting the Shadow of Mordor folder having your configuration and settings files.

Why you ask? Well, it’s a sort of a hard reset and when you relaunch the game, new files and folder will be created and hopefully the game will run fine.

If that doesn’t work or you can’t find a Shadow of Mordor folder or files at that location, you can try our next workaround.

For that, you need to create three text files in the folder: game.ini, render.cfg and settings.cfg. After the files have been created, paste the following commands as such:

render.cfg

“Render.Setting.AmbientOcclusionQuality” “0.000000”
“Render.Setting.AspectRatioLock” “1.000000”
“Render.Setting.AutoDetectedGPURating” “4.000000”
“Render.Setting.AutoDetectionVersion” “1.000000”
“Render.Setting.DepthofFieldToggle” “1.000000”
“Render.Setting.FrameRateLimit” “2.000000”
“Render.Setting.LightingQuality” “2.000000”
“Render.Setting.MeshQuality” “3.000000”
“Render.Setting.MotionBlurQuality” “0.000000”
“Render.Setting.OITToggle” “1.000000”
“Render.Setting.ShadowQuality” “2.000000”
“Render.Setting.TessellationToggle” “1.000000”
“Render.Setting.TextureFiltering” “3.000000”
“Render.Setting.TextureQuality” “3.000000”
“Render.Setting.VegetationQuality” “4.000000”

game.ini

[Game]
Build=Build 1636

settings.cfg

“DeviceAdapter” “0.000000”
“DeviceOutput” “0.000000”
“ScreenHeight” “1080.000000”
“ScreenWidth” “1920.000000”
“UIHeight” “0.000000”
“UIWidth” “0.000000”
“VSyncOnFlip” “0.000000”
“Windowed” “0.000000”
 

fernanespejo

Reputable
Oct 17, 2014
3
0
4,520
1


Thanks for the quick reply. I already have the built-in graphics disabled from the BIOS as default, so I know it's using my dedicated GPU.

I've looked at the crashwiki suggestion, and the game works just fine on startup. The problem is that after extended play time of around 30 mins - 1 hour the game just freezes. The issues spans on multiple games so I can tell that it's not the game itself that is causing the issue.
 

fernanespejo

Reputable
Oct 17, 2014
3
0
4,520
1
I've solved the problem. It turns out that the latest AMD driver is having problems with the card, so I uninstalled my driver using DDU and installed an old driver 13.12. Running stable at the moment, will revert if anything odd happens.
 

plywrlw

Admirable
Jul 5, 2014
2,811
0
7,960
474
Glad you've got it sorted. The game is pretty new so I'm sure the error with the new drivers will be fixed eventually
 

Similar threads