Question Please Help - Video Problem With Laptop + Win 10

Jan 26, 2020
2
0
10
0
Please help guys!

I have the following laptop:

Acer Aspire E5-772G-70VP (Aspire E5 Series)
ProcessorIntel Core i7-5500U (Intel Core i7)
Graphics adapterNVIDIA GeForce 940M - 4096 MB, Core: 1072 - 1176 MHz, Memory: 1920 MHz, DDR3, ForceWare 347.52, Nvidia Optimus
Memory8192 MB
, dual-channel, 2 memory banks, both filled
Display17.3 inch 16:9, 1920 x 1080 pixel, AU Optronics AUO119D, TN LED, glossy: no
MainboardIntel Broadwell-U PCH-LP (Premium)
StorageKingston RBU-SNS8100S3128GD, 128 GB
, + 1 x WDC WD10JPVX-22JC3T0 1 TB

The problem is that the video runs extremely slow and laggy. I can't even really watch anything video and websites take sometimes a minute for the graphics to load. It has the same problems with any offline video tasks as well.

I bought it secondhand from an old lady with athritis so it practically brand new.

I'm 95% sure it is a graphics driver issue because everything runs perfectly fine in safe mode.

Here is what I have tried so far.

1. I restored the machine to brand new. The video driver constantly crashed the machine then.

2. I uninstalled in Device Manager all video drivers and let Windows update them automatically.

3. I downloaded the NVideo 940m driver from their website and manually installed that.

4. Updated Win 10 to see if Windows had any kind of automatic fix.

5. Downloaded and installed the drivers directly from the Acer website. I had to uninstall them because the machine was still crashing then.

It's improved in that at least now it will turn on...

...but it's still unusable for anything video.

Please help.

How can it be fixed and run properly?
 

ASK THE COMMUNITY

TRENDING THREADS