Question "Please insert disk into removable disk"

johnjtraynor

Reputable
Jan 18, 2015
33
0
4,540
1
Hi. I purchased a TOTU USB-C hub for my Lenovo Yoga C930 running Windows 10 (occasionally booting into ubuntu but that's not relevant here) . The Yoga only has 2 USB-C and one USB 3, and I needed Ethernet, HDMI and SD slot.

It worked fine (although reception of my wireless mouse is a little glitchy when using it) until I put a sandisk adaptor with a mini sd card in to the SD card slot. The mini sd card may not be formatted properly. I can't tell.

Since that point I get the "please insert disk into removable disk X" intermittently even when the SD card is full or empty.

I have searched for and tried the usual fixes for this.

Disk X does not show up in file explorer or storage settings so I can't rename it.

In Device Manager under Disk Drives i have removed and re-added generic micro sd/m2 usb device and generic sd/mmc usb device.

I have not disconnected the Totu Hub for long but when i do remove it and reattach it the problem comes back even without using the SD card adaptor.

Any other suggestions?

Thanks
 

ASK THE COMMUNITY